Talk:BIOS Upgrade

From ThinkWiki
Jump to: navigation, search

Dead link

The link to the FreeDOS floppy (, which is needed to upgrade the BIOS from a CD, is dead. Is the information still valid? And is there a different source for the floppy image? Jamesavery 05:49, 18 February 2007 (CET)

BIOS upgrade using WINE

Does anyone think this would be possible? Mcalwell 08:58, 28 January 2007 (CET)

No this is not possible. Mcalwell 16:01, 12 February 2007 (CET)

BIOS upgrade without battery

Concerning the known problem with 600 series with batteries dead too soon, it is impossible to upgrade the bios without the battery because the original ibm update program doesn't allow this. I bought an old 600E without the battery. There was one workaround, but i think for the older releases of the bios, where you just extracted files and upgraded manualy, bypassing the ibm install program. The page that describes this (i lost the link) has a list of different files, that the ones found in current release so i never did figure out what to do? I would like to upgrade because i have really old bios, where ACPI doesn't cooperate so well with the operating system, either windows or linux.

If somebody finds a workaround please help. Thanks


I've found the page on Vim's bios upgrade forum.. I don't know if it exactly for my model, since the files differ.. Is it possible, to upgrade bios in linux without the battery?

I have found a working solution WOW on the other forum:

      • This is NOT a safe way to update the bios (disclaimer) ***
  • First you need to make a BIOS update floppy disk (from the bios file from IBM - place disk in a: drive, run app and answer Y to the agreement) and then format another disk by right clicking on A: - format - make system bootdisk (assuming you have another machine spare)
  • Copy all the files from the IBM Boot disk - in my case

$0029000.fl1 $0029000.fl2 FLASH2.EXE PROD.DAT UPDTFLSH.EXE updtrom.exe USERINT.EXE UTILINFO.EXE to the other clean bootdisk.

  • Ensure that there is no config.sys and autoexec.bat so it just runs straight into DOS.
  • Place the disk into the Laptop, reboot and allow the machine to load via the floppy
  • At the command prompt, type "FLASH2.EXE /U" with no quotes then press enter.

The program will automatically search for the files *.FL1 & *.FL2 and load the bios first then the platform file.

The program will automatically update and perform erasing on the rom and then finish with "Update complete".

  • Now reboot.
  • Hold F1 down as you turn the laptop back on and go into Easy Setup under "Config" click on Initialize to ensure defaults and settings are error free.
  • Save and exit...


This worked on my machine.. I make no guarantees it will work on others.

The above procedure did not work on my T23 using the 1.20 bios; it kept returning error 14 (Low Battery). However, following those instructions and running "qkflash" rather than flash2 did work for the main bios, and later for the embedded controller. --grythumn

// EDIT The provided solution didn't work on my R31: even with qkflash /U i get the low battery message - is there any other solution ? -- joer

Try "phlash" after renaming $0179000.fl1 to bios.rom and $0179000.fl3 to platform.bin, source: (deleted since the wiki pesters about me being a spambot). Worked on an A22e using freedos/balder which I had to boot natively - using memdisk caused phlash to stall, luckily without causing damage. --cbiedl

Bios upgrade & hidden partition

I have disabled the hidden partition to make more space for linux (24G). I still have Windows on the 14G partition. Is it safe to upgrade the BIOS without the hidden partition? I want to get a newer BIOS to fix the annoying fan issue. Thanks

- yes don't worry about it. bios upgrades have nothing to do with whats inside the harddrive.

BIOS upgrade over PXE


I have a Thinkpad X20 with a very early BIOS and Embedded Controller Program which I'd like to update. Currently, the only feasible way of doing this is over the network using PXE. I already have a fully functional PXE server using SYSLINUX, and have so far been able to boot the BIOS diskette image using MEMDISK, although I have not attempted to flash anything yet due to the warnings given on the page. Is there any safe way I can update both the Controller Program and the BIOS in the same session over the network in this manner? If not, what other methods would be suitable? I have a USB CD-ROM drive and could probably get hold of a USB floppy drive.


Update: I ended up burning CDs as described and successfully updated everything. I'd still like to know if there is a way I could do it entirely over the network, though.

BIOS upgrade on Linux with USB

I have successfully upgraded BIOS of my T400 on Linux by burning the ISO image onto USB stick with this very simple procedure presented here, section 2.5 An interlude : El Torito boot with hard disk emulation.

Can I update the BIOS Upgrade page and outline this procedure?

--Mloskot (talk) 00:03, 17 August 2013 (CEST)

RE: grub initrd

"Another possibility which works even without a CD-drive or network is to boot the disk image via the grub initrd mechanism."

0) Interesting suggestion. Might be better of in its own section.

1) Could you please elaborate?

2) My first guess (pending your elaboration) would be to "chainload" the first block of the diskimage using the grub commandline, like:

  blocklist (path)/to/diskimage
  chainloader blockvalue+1

But that's just a guess!

Paul Bolle Fri Jul 15 12:20:47 CEST 2005

bios/controller update sequence

The article says: "If you go through the readme's on the IBM site they'll cleary state that you must update the Control Program first, then imediately update the BIOS"

When I look at the IBM udpate instructions for the T23, it says: "If you need to update the BIOS as well as the Embedded Controller Program, update the BIOS first."


> I would first contact IBM for clarification, but you should probably be following instructions specific to your model.

>> I did it following IBM's instructions to upgrade the BIOS first. Everything worked out great!

Firmware upgrade for Intel minipci combo card

I just purchased an Intel 10/100 Ethernet Mini-PCI Adapter with 56K Modem that has an ancient (2.0.6) firmware version. I Downloaded the update file intlbtag.EXE but cabextract was unable to find any cabfiles inside it. I tried running the program via wine and that didn't work either.

Finally I ran the program on a windows machine and created a boot floppy. Then I went through the the process of converting the floppy to a bootable cd via linux and that worked like a charm. The cd successfully updated the minipc card's firmware.

Everything worked but I ended up needing a windows box to do it. Could this have been done without windows?

Firmware upgrade for Wireless LAN MiniPCI COMBO Card using prism2_srec

The appropriate firmware installation program for the wlan card in my R32 can be extracted using cabextract as described in the article. It contains (besides some installation programs) a disk image (1awg06ww.IMG) that seems to be a simple dos boot disk. This image contains 3 .hex files (id010001.hex, pk010100.hex, sf010402.hex) that are recognized by prism2_srec to be "srec"-files. Trying to load them to RAM yields:

   # prism2_srec -v -r wlan0 sf010402.hex
   S3 CRC-16 generation record: start=0x007E1800 len=65642 prog=1
   Start address 0x00000000
   srec summary for sf010402.hex
   Component: 0x001f 1.4.2 (station firmware)
   Interface compatibility information:
   role=Supplier variant=2 range=1-9 iface=Station Firmware-Driver (4)
   role=Actor    variant=1 range=1-1 iface=Modem-Firmware (1)
   role=Actor    variant=2 range=1-1 iface=Controller-Firmware (2)
   role=Actor    variant=1 range=4-4 iface=Primary Firmware-Driver (3)
   Wireless LAN card information:
   NICID: 0x8013 v1.0.0
   PRIID: 0x0015 v1.0.7
   STAID: 0x001f v1.3.6
   Interface compatibility information:
   PRI role=Supplier variant=1 range=1-1 iface=Modem-Firmware (1)
   PRI role=Supplier variant=2 range=1-1 iface=Controller-Firmware (2)
   PRI role=Supplier variant=1 range=4-4 iface=Primary Firmware-Driver (3)
   STA role=Supplier variant=1 range=1-9 iface=Station Firmware-Driver (4)
   PRI role=Actor    variant=2 range=1-1 iface=Controller-Firmware (2)
   STA role=Actor    variant=2 range=1-1 iface=Controller-Firmware (2)
   STA role=Actor    variant=1 range=1-1 iface=Modem-Firmware (1)
   This image is not meant to be downloaded to volatile memory.
   Incompatible update data.

Has anyone tried to flash this device using prism2_srec yet? What bothers me is, that the upgrade is for many different parts of the combo card. Does anyone have an opinion on whether this could work?

OK, I took the risk and successfully upgraded my station firmware, BUT when I tried to upgrade the primary firmware the system froze!!! The thinkpad won't start up with the miniPCI card inserted and all efforts to reflash it using the original DOS boot image failed!!!

I'm quite sure the system freeze was not caused directly by prism2_srec, because I have noticed rare system freezes since I have been using my PCMCIA wireless card. Anyway, if anyone should own a TP R32, I'd be glad if he could tell me the base address of the Wlan card, or it's PCI address.

Thinkpad r32 owner here. I want to upgrade the firmware as well. If you need any information just send an email to haftbar[a] Quickie 02:12, 1 February 2006 (CET)

Reorganization suggestion

The Downloads section is rather long. Would it be an idea to put it on a separate, new page (say: BIOS_Downloads) and link to that new page from this page?

Paul Bolle 21:27, 15 Oct 2005 (CEST)

> I agree with this suggestion.

Upgrading BIOS and Embedded Control Program from Win XP

I'm trying to upgrade the BIOS and Embedded Controller Program from Windows XP following the instructions on the Lenovo website. The problem is the instructions are not very clear about this. The instructions basically state that I must upgrade them at the same time because the Control Program does not work with the older BIOS and the BIOS does not work with the older Control Program. They also state that I should upgrade the Control Program first.

But that means I must boot into XP after having upgraded the Control Program but with the older BIOS in order to then update the BIOS. But if this works then they are actually compatible and there's a contradiction. Am I missing something? I just want to make sure I don't end up with a non-functioning unit.

I have an X23 and want the latest BIOS (v 1.32) and Control Program (v 1.30).

Maybe there should be a note about this in the article? Or maybe I'm the only one who is this stupid :)

Update: I talked to Lenovo support. The situation apparently is that though the description says that the newer control program is not compatible with the older BIOS, they are not so incompatible as to cause the machine to stop working so it is actually possible to use incompatible versions of BIOS and control program. In fact according to the support person it makes no difference if the BIOS is upgraded before the control program or vice versa. So I upgraded the control program using the executable running in Windows XP, which rebooted the computer to perform the upgrade and then I booted Windows again to upgrade the BIOS in the same manner and it all worked fine. If anyone reading this finds it useful maybe you can put it in the article? Or if you find it superfluous just delete this section.

--xphinx 12 March 2007

I have an X22 with BIOS version 1.21 and Embedded Controller version 1.17 and using the steps described by you, I succesfully updated my bios to the lastest versions from WindowsXP (BIOS v1.32 / EC v1.30) Thanks!

BIOS upgrade for T21 with T20 BIOS

Hi, I bought a used T21 recently (type 2647-8AU), and would like to update the BIOS to the latest version, but there's a problem: this T21 appears to have a T20 BIOS (IYET50WW, a/k/a T20 BIOS version 1.11). When I try updating this BIOS using one of IBM's T21 updaters - I tried KZET34WW/v1.16 (the latest one) and KZET16WW/v1.01 (the earliest one) - I get the following message:

The diskette in the default drive will not run on this system. Your system is now locked. To restart your system, press Ctrl+Alt+Del.

I suspect this message appears because the existing BIOS is a T20 BIOS.

There would appear to be two options: either use the most recent T20 updater (IYET61WW, a/k/a T20 v1.22), or find a way to defeat the block in the KZET34WW/v1.16 T21 updater. Obviously either option is risky in the absence of more information and/or detective work. And I don't know enough about T2x-series hardware to hazard a guess (i.e., were early T21s just T20s with a speed bump, did some T21s get T20 BIOSes by mistake due to factory error, or are the T20 and T21 similar enough that it doesn't matter whether a T20 or T21 BIOS is used).

Some relevant data gleaned from the stickers on the case bottom and the current BIOS:

  • Type: 2647-8AU (T21 with 800-MHz processor)
  • S/N: 78-0GL1Z (zero-G-L-one-zed)
  • Manufacture date: 03/2001
  • BIOS version: IYET50WW (T20 BIOS v1.11)
  • System unit S/N: (appears to be blank)
  • System board S/N: J1HHS15CL5C
  • System board P/N: 08K3747 (printed on motherboard)

Thanks for any help anyone can provide.

-Linux Spice

P.S. At first I thought this might be a Frankenstein ThinkPad with a T21 case and a T20 logic board - I did buy it used, after all - but it does have an 800-MHz processor, which was never an option for the T20 (both the BIOS and Linux report it as such), and all the other equipment checks out (except for the hard drive, which was replaced with a 40-GB model).

Force Upgrade a Thinkpad T20 to latest Thinkpad T22 BIOS

i managed to force upgrade my t20 to a t22 bios using a strange method.

i snagged a "bios bootdisk" from (it's a drdos/caldera dos boot disk), wrote the image to a floppy disk, then copied to it the PHLASH.EXE flasher, $0179000.fl1 (renamed to BIOS.BIN) and $0179000.fl3 (renamed to PLATFORM.IMG) from the T22 1.06 update from ibm/lenovo's site. i think any lower version would work, but it tried it with that. anyways.

i inserted the disk into the thinkpad t20, booted off of it, then ran PHLASH. it reflashed the t20 with the t22 1.06 image no problem. now the machine's in a frankenstein state...t22 bios, t20 ec, etc. i took the floppy out (or made another floppy, whatever), wrote to it the latest available update from ibm/lenovo (at the time of writing, although i doubt it will ever be updated again, is 1.12), booted the thinkpad t20 off of it, and the bios reflash disk was satisfied that the machine was a t22. more waiting, and the thinkpad t20 is now a thinkpad t22! for me, it means no more waiting for the machine to count memory every single boot (it remembers the value and quick boots now), and it perfectly supports my 1400x1050 display from a damaged thinkpad t22!

end result: reflashed a thinkpad t20 with the latest thinkpad t22 bios, and now the machine presents itself as a thinkpad t22. the hardware's similar enough that it can pass itself off as such just fine.

hope others can share in my success.

--SaturnNiGHTS 15:49, 11 May 2008 (EST) (also uses "SatNiGHTS" on IRC)

BIOS format

Not sure if this is the right place, but... Does anybody know what the formats for the various files are in the bios package (or, even better, the bios.bak file that gets dumped on your disk before updating)? I'm getting progressivel lower and lower level in figuring out just what happens when the computer boots, and the BIOS is the last step... (BTW, I have an x60s)

-- Unknown

Yes. It is a binary dump. Sometimes, there is junk in the start of the file. This should be data enough for you to figure out what you need.

--hmh 13:30, 26 February 2007 (CET)

BIOS update gone bad

I tried to flash my ThinkPad 600's bios with catastrophalic outcome; now the machine is unable to boot. I, being overly stupid and too self-confident, ignored all warnings about the media containing the bios image not being write-protected (I used one partition of the disk, in which I had installed FreeDOS). During the updating process, the machine started to write screens full of random characters in cyan coloured background. At that point I knew it was b0rked. I asked my friend about what to do now, he said I could open the machine up, locate the bios chip and use EPROM programmer/burner to write the bios image to the chip. He also said that because my machine is very old, there are probably not safeguards like dual bios or emergency bios update from floppy disk on boot. He continued by saying that the bios update file images from IBM/Lenovo website might not be actual , "pure" binaries which could be burned directly to the chip, instead they may contain some vendor-specific checksums which must be taken into account. In ThinkWiki there seems to be no page about bios flashing gone bad and restoring the machine to working condition. Or is there? I really need your help with this; I think I'm able to locate the bios, take it off and find a working EPROM burner, but where can I get a clean BIOS image without the vendor checksums? I'd be grateful for any references.

--Usv 12:45, 31 March 2007 (CEST)

BIOS upgrade using USB flash drive

I flashed my Thinkpad X41 succesfully with 2.09 BIOS using bootable USB flash drive with DOS 6.22 system files. (I guess Freedos would work aswell). I had such key laying around so I can't help you with making one (i used windows HP USB key format utility to make it long long time ago) Everything is quite simple once you have USB key and are able to boot DOS from it.

I downloaded the non-diskette ThinkPad BIOS update utility (74uj15us.exe) from lenovo support site and extracted the disk image from it using cabextract:

  $ cabextract -F "*.IMG" 74uj15us.exe

I mounted the image file (74UJ15US.IMG):

  # mkdir /tmp/mnt
  # mount -o loop 74UJ15US.IMG /tmp/mnt

I mounted the usb key and made a directory for ibm flash utility files under it:

  # mount /dev/sdb1 /mnt/usbflash
  # mkdir /mnt/usbflash/ibm

I copied the contents of /tmp/mnt to /mnt/usbflash/ibm:

  # cp /tmp/mnt/*.* /mnt/usbflash/ibm

Then I unmounted the USB stick and rebooted from it to DOS (F12 during boot -> USB HDD).
In the DOS Prompt:

  C:\cd ibm
  C:\IBM\flash2 /U

I waited for about 1 minute, then my thinkpad made two beeps to signal that the flashing was complete.

PS. Because lacking reliable guide on how to make bootable DOS USB stick for ThinkPads I decided to leave this into discussion section. Please feel free to move/edit all the necessary stuff into the BIOS upgrade article if you know/figure out how to make bootable DOS USB stick in linux. I tried various tutorials including, but didn't manage to boot into the Freedos prompt. --ladoga 04:56 17 Apr 2007

Reserving RAM for my X3100 graphics card

Is there any way in the BIOS to reserve memory for my graphics card? I have 2 GB of RAM, which is more than enough for general system processes so I'd like to allocate some to my Intel graphics card. SteveSims 19:36, 5 November 2007 (UTC)

BIOS Doesn't want to install

During the install process on a Z60m, I get the error message, "An update is not necessary at this time. The process has been canceled." The program is right, I am using the same latest BIOS version. However, I have a different, new boot splash image on it. I was wondering if there were any way to force a reflash - the program gives me no way around this.

Turns out that I had put the bios splash on incorrectly. It should reflash if you change the splash image. But in case you needed to reflash an identical bios for any reason, one thing that worked for me was downgrading and then upgrading.

Converting Current BIOS CD-ROM for USB Flash boot

The latest Lenovo BIOS releases in bootable CD-ROM format (for the X200 in my case) are using hard disk emulation rather than floppy emulation.

I peeked at the ISO with hexdump and found the hard disk image, including its MBR and partition table, starting at byte offset 0xd800 in the particular image I inspected. I won't explain the crude way I found this, but it was easy to verify. I used "tail -c +55297 foo.iso > boot.img" and then loaded this up in a loopback device to verify that fdisk saw a proper partition table.

Simply dumping this image to a USB flash drive via dd if=boot.img of=/dev/sdb then created a bootable drive and I successfully booted this and updated my X200 BIOS. Your mileage may vary...

-- karlcz Oct 16 16:09:40 UTC 2008

Floppy Disk, Failure Mode

I've just had the mispleasure of toasting my wife laptop during a floppy HC4 flash. The problem was that the read from floppy failed with 'abort, retry, fail'. After a couple of 'retry' attempts, I mistakenly hit 'fail' (rather than 'abort'). The program then decided to flash with whatever it had in memory and toasted the machine (which will not turn on at all now).

--Mungewell 15:09, 29 August 2009 (UTC)

Huge Re-write

I found this page to be horribly confusing and hard-to-read. There was a fair bit of duplication, e.g., using memdisk to boot from GRUB was covered at least twice. There was some clutter, e.g., discussion of cleaning floppy drive heads. And just a general disorganization. So, I decided to "fix" it.

I broke the update ("upgrade") process down into two basic steps: how to get the right file, and how to install it. I moved things around based on that basic structure, and then re-formatted a lot of stuff. So, the page contents look much more different than they actually are.

Please check for technical accuracy if you have a moment. -- Pi3832 07:46, 15 December 2009 (UTC)

Moving "testing" tables

The tables of what models have been tested with various methods are great info, but take up a lot of space on the page. Maybe they should be sub-pages? -- Pi3832 07:46, 15 December 2009 (UTC)

Wrong mkisofs/genisoimage commands will just get people stuck

Giving people the following example will just get them stuck!

$ genisoimage -b bootfloppy.img -o bootcd.iso 1WUJ25US.IMG #or mkisofs for older systems
genisoimage: Uh oh, I cant find the boot image 'bootfloppy.img' !

The proper example needs to be

$ genisoimage -b 1WUJ25US.IMG -c boot.catalog -o bootcd.iso 1WUJ25US.IMG

See [1]. Jidanni 23:53, 23 January 2010 (UTC)

new File Formats ??

Could it be that Lenovo changed the Fileformats ? Neither the ISO nor the .exe seem to work as described in the Wiki :( --Stechlinger 17:20, 4 March 2012 (CET)

Problems with X after BIOS upgrade from 1.05 to 1.48 on Thinkpad T410s with Intel graphics

I am seeing decreased X performance after I upgraded the BIOS in my T410s with an i5 520-M from 1.05 to 1.48 using the Lenovo CD. After disabling PCI and PCIe power-saving these problems got less severe, but still persist. Specifically, changing large areas of the screen (1920x1200 external screen), such as a switch from one virtual workspace to another, _sometimes_ causes the redrawing to hang for a second or two.

I am using Debian Testing with current

  ii  xorg                                 1:7.6+12                        X.Org X Window System
  ii  xorg-docs-core                       1:1.6-1                         Core documentation for the X Window System
  ii  xserver-xorg                         1:7.6+12                        X.Org X server
  ii  xserver-xorg-core                    2:                  Xorg X server - core server
  ii  xserver-xorg-input-evdev             1:2.6.0-2+b2                    X.Org X server -- evdev input driver
  ii  xserver-xorg-video-intel             2:2.18.0-1                      X.Org X server -- Intel i8xx, i9xx display driver

and Xfwm4. Anybody seeing similar problems? ← Downgrade to 1.05 fixed the problem. :) --X2017 20:18, 9 March 2012 (CET)