Madwifi

From ThinkWiki
Revision as of 23:11, 11 March 2009 by Tonko (Talk | contribs) (old crud)

Jump to: navigation, search

Madwifi (Multiband Atheros Driver for Wifi) is Linux driver for 802.11a/b/g universal NIC cards - Cardbus, PCI, or miniPCI - using Atheros chip sets.

The following (incomplete) list of adapters sold by IBM use the Atheros chips:

  • (11a/b/g/n) Atheros Communications, Inc. Unknown device 0024 (rev 01) (using SVN revision 2360+)

Packages

Source

Detailed instructions can be found on the MadWiFi Wiki.

$ svn checkout http://svn.madwifi.org/trunk madwifi-ng
  • madwifi-old:
$ svn checkout http://svn.madwifi.org/branches/madwifi-old madwifi-old


Installation

  • Make sure that you've got sysctl support and the net/radio enabled (wireless extensions) in your kernel. Install the driver with make & make install
  • further more you like to install the wireless tools from wireless tools. Make sure the versions fit together by
$ iwconfig --version

Setting up wpa_supplicant with wpa-psk.

You can enable the wireless LAN status LED on your Thinkpad by following these instructions (tested on Thinkpad x60s).

Status

Release 0.9.3[1] available

Release notes

   * switch to newer HAL, v0.9.18.0
   * ensure compilation against recent kernel versions up to 2.6.20
   * ensure compatibility back to kernel 2.4.22, drop support for 2.4.21 and older
   * allow compilation without support of features such as fast frames, turbo mode, etc.
   * support for some PCI Express cards fixed
   * some security-related issues have been patched
   * interoperation with wpa_supplicant and hostapd improved
   * real channel noise instead of fixed -95dBm noise floor presented
   * lots of bugs fixed, for different architectures and various modes of operation
   * further improvements for build system

Free Software HAL

The old madwifi driver consisted of a BSD/GPL wrapper with an unmodifiable HAL (Hardware Abstraction Layer). This HAL was not binary firmware as with the Intel wireless chips, but a piece of code that needed to run in the Linux kernel. It consisted of header files for which no permission to modify was granted, and pre-compiled object files. The vendor's position was that the Linux community simply needs to accept this sourceless HAL, since in principle the Atheros chip could be tuned to any frequency, and thus produce RF interference with systems operating in those frequencies.

This binary HAL was unacceptable to the Linux kernel developers, and the Atheros driver in this state would never have become a part of the official kernel. Some OpenBSD developers, facing the same issue, clean-room reverse-engineered the binary HAL and had produced an open source driver (ath5k), which was subsequently picked up by the madwifi team as the future direction. At the same time the old madwifi driver was labeled 'legacy' to reinforce this point.

In the meantime the ath5k driver has been merged into the linux kernel, and Atheros has come around and hired a linux kernel developer, released a second driver (ath9k) for newer wireless chips and has taken over maintenance of the ath5k driver.

As of the latest distributions (Ubuntu 8.10 and Fedora 10) the atk5k driver is still flaky, but those problems seem to be resolved with the latest mainline kernel (2.6.29).


Problems on Fedora Core 9

When installing madwifi 0.9.4 on my new machine (from source), ath_pci would load fine, apparently, but I could only see the wlan0 interface via iwconfig, and no attempt to create an ath0 interface or start it (via ifconfig) would work. I finally found the problem (described in this email trail) which indicates the new ath5k module is the problem.

As directed, I fixed it by editing /etc/modprobe.d and creating a file called madwifi with the following in it:

alias wlan0 ath_pci
blacklist ath5k

Although this enables ath0, I have yet to get the wirelss to actually connect to anything.

Using Madwifi with SUSE Linux 10.1

As of SUSE Linux 10.1, the Madwifi packages are no longer included in the SUSE distribution because of the presence of closed source code. However, I was able to download, install, and configure Madwifi for my IBM T40 with the IBM 11a/b/g Wireless Adapter (Atheros AR5212 802.11abg) as follows:

  • Start yast2 and select Software--Installation Source. Add http://madwifi.org/suse/ as a source
  • Install packages madwifi and madwifi-kmp-default (the latter has the kernel module, replace default with smp or other non-default kernel package if you're not running the default Suse kernel package as determined by uname -r)
  • Reboot so the kernel modules can be loaded.
  • Load the kernel modules by hand and see if the kernel recognizes your hardware:

modprobe aes; modprobe wlan_ccmp; modprobe ath_pci; lsmod |egrep 'Module|aes|wlan|ath'

  • If recognized, put the modprobe lines above in your /etc/init.d/boot.local file. Otherwise, check for Linux kernel/Madwifi incompatibilities and hardware issues.
  • Start yast2 and go to Network Devices-->Network Card and add and configure your wireless card. I recommmend checking the "Network Manager" box, as that allows dynamic GUI control over the wireless and Ethernet NICs.
  • I have WPA-PSK enabled, so here's the fields I filled out: "User Controlled" device activation, DHCP Automatic Address Setup, "Managed" operating mode, "any" ESSID, "WPA-PSK" auth mode, key input type "passphrase" and I typed in my passphrase. I left expert settings alone.

External links