Talk:Installing Fedora Core 5 on a ThinkPad 600X

From ThinkWiki
Jump to: navigation, search

OK people, I'd like some help here. At this point, FC5 is running, but some devices are not working.

Here are my choices:

Option 1: Try to get things working with the current packages. On the plus side, the guide will always for FC5 on the 600X because the FC5 distribution is fixed. On the minus side, a lot of work may already have been done for me.

Option 2: Get on the net, yum update then get things working. Plus: Some things might just work. (I think sound will work, for example.) Work saver. Minus: This guide is a snapshot of the latest FC5 updates as of right now... meaning the guide requires maintenance or is out of date.

Opinions welcome. --Whizkid 16:24, 26 April 2006 (CEST)

After installing on a 570, and updating the packages, sound worked just fine, so I'll do an update and go from there. --Whizkid 16:29, 30 April 2006 (CEST)

Updating it is

I decided to update the packages and go from there. The sound started working immediately... so I got that going for me. :) --Whizkid 14:06, 3 May 2006 (CEST)

FC5 installation problems on 600x

I am trying to get FC5 onto my 600x, but I'm getting a "Fedora Core CD was not found" error. I've unsuccessfully tried a few install options (acpi=off, apm=off and others). I've installed fc4 and other flavours of unix on several Thinkpads till now, but this is stumping me. --Cheers, Miguel

Have you tried using turning off DMA? Try the ide=nodma install option. BrianTung 10:00, 10 May 2006 (CEST)
Also try the acpi=noirq or acpi=off options --Tonko 10:36, 10 May 2006 (CEST)

Thanks for the suggestions, guys, but no go using any of those. To make things worse, a DVD install is also failing. The media checks okay using the installer's test, but I get an error midway through. (Some rpm cannot be read, the exact one depending on the install options I use.) Will try to install FC4 and then upgrade from DVD, though I'd really like to know what is up!

You should not need any options during the install. Make sure you have the latest BIOS. I would not expect a DVD install to work, at least using the DVD drive that came with the 600X: It was not meant to read recordable DVD's of any type. You only need the first two CD's if you turn off all three software choices, and the drives that came with the 600X should read CD-R's if not CD-RW discs. If you're using CD-RW, try CD-R. When exactly do you get that error message? (Please sign your messages with the signature button. Thanks) --Whizkid 21:54, 17 May 2006 (CEST)

Re the CD-RW vs CD-R issue, the same brand disks burn an FC4 set good for installation on the same system.

Here's the successful kludge I used in the end: boot from CD1, get the "CD not found error", slip in the DVD, DVD _is_ recognized, and go from there with a fairly small package selection. For what it's worth, the options I used for the last (successful) attempt were: pci=noacpi noapic, nolapic, what I had needed before to make ubuntu live load. Onyoursnow 13:59, 19 May 2006 (CEST)