Talk:How to get SpeedStep working on Coppermine-piix4-smi based ThinkPads

From ThinkWiki
Jump to: navigation, search

speedstep-smi fails to load if CONFIG_CPU_FREQ_DEBUG is not set

On a ThinkPad T22 I was not able to use speedstep-smi if CONFIG_CPU_FREQ_DEBUG is not set. See this bug report:


On a Thinkpad T20 using Debian unstable and a stock kernel, building the kernel with CONFIG_X86_SPEEDSTEP_RELAXED_CAP_CHECK=y doesn't seem to show the error you're experiencing while loading speedstep-smi. So that means loading speedstep-smi module results to no error at all.

Jan Alonzo 22:38 28-05-2022

From the kernel config:

 ┌────────────────────── Relaxed speedstep capability checks ──────────────────────┐
 │ CONFIG_X86_SPEEDSTEP_RELAXED_CHECK:                                         │
 │                                                                                 │
 │ Don't perform all checks for a speedstep capable system which would             │
 │ normally be done. Some ancient or strange systems, though speedstep             │
 │ capable, don't always indicate that they are speedstep capable. This            │
 │ option lets the probing code bypass some of those checks if the                 │
 │ parameter "relaxed_check=1" is passed to the module.                            │
 │                                                                                 │

this option only lets you use relaxed_check=1, it doesn't solve anything. this may mean that your model isn't affected at all, or that you have the described file in /etc/modprobe.d

ondemand t22

I would like to know if ondemand is possible on a t22. Also I'm wondering why cpu speed is only either 700mhz or 900mhz.

In /proc/acpi/processor/CPU/throttling there are 7 states defined, but changing them seem to does not do anything. Also cpudynd -acpi tells me there is no interface. I tried also to use acpi-cpufreq but it won't run because 'no such device'. How to use it?

Thx in advance, nusse.

no cpufreq interface found ?

I had a hard time to figure out that for cpufreq you also have to install (at least a subset of?) the modules


I used modconf where I found these modules listet under "kernel/drivers/cpufreq" tagged as "not installed".

I am a newby using Debian Sarge on a Fujitsu Siemens Amilo D, with a Pentium III (Coppermine). However this information might also apply to thinkpads.

Trouble with 2.6.15

I am using linux-image-2.6.15-1-686 and speedstep-smi won't load anymore. Again 'no such device' error. No idea why yet. User:Daniel_X21

Yep, there is a new bug with new kernels... See the link to bug at the begin of this page. The 2.6.16 resolve the bug for me. (On a ThinkPad X20). --Julienbras 10:24, 10 April 2006 (CEST)

Did not work on A21e

I tried following this guide on my A21e and had no luck.

I got the following in the log using boot param cpufreq.debug=7

 speedstep-lib: x86: 6, model: 8
 speedstep-lib: Coppermine: MSR_IA32_EBL_CR_POWERON is 0x46c80020, 0x0
 speedstep-lib: Coppermine: MSR_IA32_PLATFORM ID is 0x0, 0x5c370000
 speedstep-smi: signature:0x47534943, command:0x008200b2, event:0x00c000b3, perf_level:0x07d00000.
 cpufreq-core: trying to register driver speedstep-smi
 cpufreq-core: adding CPU 0
 speedstep-smi: trying to obtain ownership with command 47534982 at port b2
 speedstep-smi: result is 2
 speedstep-smi: fails in aquiring ownership of a SMI interface.
 cpufreq-core: initialization failed
 cpufreq-core: no CPU initialized for driver speedstep-smi
 cpufreq-core: unregistering CPU 0