Talk:ATI Mobility Radeon X1400

From ThinkWiki
Jump to: navigation, search

Hi - I'm having major trouble installing linux on my T60 intel core 2 duo with ati mob. radeon x1400. Here are the issues i encountered: 1. Failure to partition my hard drive (either from text installation nor with partition magic 7) 2. Installation freezes with screen/resolution error, stating it will restart within 2 minutes - same with Ubuntu 7.1 and Fedora 8 3. Installation with Alternate installation of ubuntu 7.10 stopped at partition b/c it cannot follow through with the partition (error) 4. Fedora 8 installation DVD does not work but Live CD does load into the Fedora Live desktop. Though when I tried to install it from here, I still ge the error with partition.

Please give me any kind of input/suggestions or point me to the right forum where I can read more into it. Thank you so much!


framebuffer at 1680x1050?

hey guys - did anyone of you get the framebuffer to 1680x1050? vesafb works well with 1280x1024, but not more. maybe with vesafb-tng from the patch fails here with 2.6.16 and 2.6.17 :( (yes, I posted this question already to Category_talk:Z61m, but never got a reply there)

I've not been able to get vesafb above 1280x1024 either, and didn't see any screen output from vesafb-tng when I tried it. --Jescombe 15:40, 28 August 2006 (CEST)

Use lower color depth -- just added an entry into main article i use 1400x1050 and highcolor (16bit)

Hm, which vga-mode is it -- what vga=XXX did you append to your boot-params? --Zhenech 14:39, 15 May 2007 (CEST)
Well, after googling I found 0x13b, 0x142, 0x145 and 0x148, adding 0x200 and booting -> only 0x145 works and fglrx isn't able to initialize the display afterwards, also tested 0x144 and 0x143 with same results. :( --Zhenech 15:44, 15 May 2007 (CEST)
Hadn't looked at this for a while, but just tried again with vga=0x344 and appears to be working fine.. (Note - haven't tested with fglrx or the avivo X drivers yet, but the vesa X driver is ok).--Jescombe 15:40, 28 August 2006 (CEST)

Sorry, my ignorance. I was talking about the X vesa driver, not the vesafb kernel framebuffer. Better do better reading from now on. :-( I removed the entry from the article.