Installing Debian 6.0 (squeeze) on a ThinkPad X220

From ThinkWiki
Jump to: navigation, search

(Please note: One user reported that the Debian 6.0 (Squeeze) installer did not include a driver for the Ethernet card in the X220. It is possible that this is due to hardware differences between models. Please check that your hardware is supported. As described below, the 4291 model works.)


Debian Squeeze can be installed without problems on the ThinkPad X220 (4291 model) using the 6.0.3 DVD.

However, wireless does not work out of the box. Also, in order to get the GPU to work properly, it is necessary to install newer X and kernel packages from Backports.


Install the iwlagn kernel module as described in the Debian wiki (instructions are pasted below):

Add a "non-free" component to /etc/apt/sources.list, for example:

# Debian Squeeze/6.0
deb squeeze main contrib non-free

Update the list of available packages and install the firmware-iwlwifi and wireless-tools packages:

# aptitude update
# aptitude install firmware-iwlwifi wireless-tools

The necessary kernel module should be automatically loaded. If necessary, it can be manually loaded via:

# modprobe iwlagn

Verify your device has an available interface:

# iwconfig

Raise the interface to activate the radio, for example:

# ifconfig wlan0 up

Additionally, I had to pass the parameter 11n_disable=0 to the iwlagn module. Either do this:

sudo modprobe -r iwlagn
sudo modprobe iwlagn 11n_disable=0

...or create the file /etc/modprobe.d/intel-5300-iwlagn-disable11n.conf with the following content:

options iwlagn 11n_disable=0

Then reload the wireless driver:

sudo modprobe -r iwlagn
sudo modprobe iwlagn

It might be necessary to repeat the last step a couple of times.

Newer kernel

Add the following line to /etc/apt/sources.list (or add a new file containing the line in /etc/apt/sources.list/d/):

deb squeeze-backports main

Run apt-get update.

Install the new kernel image:

apt-get -t squeeze-backports install linux-image-2.6-amd64


Backports instructions.


It is necessary to install a newer version of X from Backports. Please refer to this page for instructions.