Intel WiFi Link 5100/5300 WLAN controller

From ThinkWiki
Revision as of 00:24, 20 March 2010 by Yak (Talk | contribs) (Lenovo Partnumbers)

Jump to: navigation, search

Intel WiFi Link 5100 and 5300 WLAN controller

This is a Mini-PCI Express WiFi Adapter, supported by the iwlagn driver since the 2.6.26 kernels.

Features

  • Chipset: Intel 5100 and 5300
  • IEEE Standards: 802.11a, 802.11b, 802.11g ,802.11n

WiFi Link 5100

  • 1x2 MIMO up to 300Mbps
  • PCI ID: 8086:4237

WiFi Link 5300

  • 3x3 MIMO up to 450Mbps
  • PCI ID: 8086:4236

Intel WiFi Link Adapter

Lenovo Partnumbers

Models featuring this Technology

WiFi Link 5100

WiFi Link 5300

External Links

Kernel 2.6.27-rc5 (as a patched kernel 2.6.26)

  • download linux kernel 2.6.26
  • download linux kernel prepatch 2.6.27-rc5

(http://kernel.org/pub/linux/kernel/v2.6/testing/patch-2.6.27-rc5.bz2)

  • make menuconfig

Device Drivers => Network device surppot => wireless LAN

CONFIG_WLAN_80211=y
CONFIG_IWLWIFI=y
CONFIG_IWLCORE=y
CONFIG_IWLWIFI_LEDS=y
CONFIG_IWLWIFI_RFKILL=y
CONFIG_IWLWIFI_DEBUG=y
CONFIG_IWLAGN=y
CONFIG_IWLAGN_SPECTRUM_MEASUREMENT=y
CONFIG_IWLAGN_LEDS=y
CONFIG_IWL5000=y
  • make && make modules_install
  • cp arch/i386/boot/bzImage /boot/kernel-2.6.27-rc5
  • install wpa_supplicant
  • now enjoy your new wireless card :)

alternative if you want to use your stock < 2.6.27 Kernel

See http://ubuntu-virginia.ubuntuforums.org/showpost.php?p=5710211&postcount=4

Debian with kernel 2.6.28

  • Get the Microcode

Download the iwlifi-5000 tarball with microcode (firmware) from IntelLinuxWireless

  • Extract the contents of the tarball:
tar xzf iwlwifi-5000-ucode-5.4.A.11.tar.gz

(filename could be different)

  • Copy the microcode file to /lib/firmware:
sudo cp ./iwlwifi-5000-ucode-5.4.A.11/iwlwifi-5000-1.ucode /lib/firmware

(the directory name extracted from tarball could be different as well)

  • Add repository

Add the following line to your /etc/apt/sources.list:

deb http://kernel-archive.buildserver.net/debian-kernel trunk main
  • Update your local package index:
sudo apt-get update
  • Install linux-image-2.6.28-1-686
sudo apt-get install linux-image-2.6.28-1-686

If you need the headers

Finally, if you need linux-headers-2.6.28-1-686, for instance to install propietary ATI drivers, then you'll have to satisfy the dependency of linux-kbuild-2.6.28. This package is not in the repositories, but you can build it yourself following the instructions at:

See section "How to build linux-kbuild-2.6 yourself"

sidux 2008-03

See How to install Intel Device 4236 under sidux 2008-03 (Ουρέα) for more info.

Further resources and information