From ThinkWiki
Jump to: navigation, search
  • Gentoo
    • I got the same problem with this card as below. I need to remove driver (rmmod iwl4965) and load it once more to make new connection. Sometimes I also need to turn wireless off and on via hardware switch then reload driver modules and then KNetworkManager finds wireless networks and I can connect. Quite irritating thing, but when it make connection it has high power and low latency.

--nysander 09:45, 07 January 2008 (CET)

  • Kubuntu Feisty
    • I can only get the adapter to make one wireless connection per boot. If I get kicked off wireless or I try to change AP's I have to reboot. The restricted IPW driver tends to destabalize the system. The IWL driver is much more stable but still has the same connection problem. Any thoughts?? Lenovo R61i.

--Trogdor282 15:10, 16 November 2007 (UTC)

  • Ubuntu
    • [quote]Works out of the box in edgy. Requires restricted repository.[/quote]

Are you sure? I installed Networkmanager (from main - I have a WPA enabled router) and WiFi worked immediately. No need for any additional tasks.

--Ro 08:37, 7 December 2006 (CET)

  • Ubuntu
    • With Edgy, all you have to do is install the linux-restricted-modules-generic package.

It works out-of the box in edgy (on a Z61m) without the need to install any additional packages, so I changed this info.

--Ro 17:19, 27 November 2006 (CET)

  • Ubuntu
    • Ubuntu Dapper has already built in this drivers; it works out from the box.

Ubuntu (neither Dapper nor Edgy) have the ipw3945 drivers, so I've deleted the info. --Zhenech 15:19, 27 September 2006 (CEST)

According to this:

All you have to do is to install the linux-restricted-modules-generic package. I've tested this using Edgy - it worked out of the box on a T60.

Sharing experience

I understand that considerations below might not necessary be of importance for everybody, however since I owe this card I thought I share few of my own experiences with it. Card: 1) lacks promiscuous mode sniffing capability in Windows (which I feel is must for most network techs and security oriented people). 2) does not work with aircrack tools 3) in order to see what is current signal strength it is necessary to hover mouse over icon on taskbar and read info from pop-up baloon (bit irritating). Strengths are shown as “Good”, “Fair”, “Poor” etc. I feel much preferable way of displaying signal strength is to present users with dynamically changing visual meter in card utility, which show signal in decibels as oppose to say “Fair” - God knows what and how many db. 4) to see what type of encryption network use (as visible in all networks view) in cards utility, it is necessary to hover mouse over a network name and read info from pop-up balloon (irritating again). 5) values from network properties as MAC for instance cannot be copied to clipboard. 6) to my knowledge it is not possible once card is installed, to disable cards connection managing utility and allow Windows to manage wireless connections.

  • Most of the above points seem dependent on the software you use, not the card or driver. Using "iwconfig wlan0" I can see "signal level" in dBm (and it seems precise). The aircrack tools work for me too except for aireplay-ng (but then maybe I'm doing something wrong). --Pflanze2 12:36, 11 October 2009 (UTC)

My wireless works on Ubuntu 8.04, but I cannot connect to wireless N

In windows in order to connect to my Wireless N network (WTG300N) I need to setup my auth as WPA2 with AES. This is the only way it will work. I've tried to configure that manually with linux and automagically with wicd, but neither of them allow me to connect to my network. I keep getting "wlan0: AP denied association (code=18)" errors in my syslog. Any ideas on what I can do?

In /etc/network/interfaces i have

auto wlan0
#iface wlan0 inet dhcp
iface wlan0 inet static
wpa-driver wext
wpa-ap-scan 1
wpa-proto RSN
wpa-pairwise CCMP
wpa-group CCMP
wpa-key-mgmt WPA-PSK
wpa-psk <MYKEY>

802.11n support as of kernel 2.6.25

I managed to get 802.11N to work work with my D-Link DIR-615 AP by building my own kernel on Ubuntu 8.04, and with the stock 2.6.25 kernel driver on Debian unstable.

The wireless tools do not yet (July 2008) support N. If you're seeing a bit rate of 0 Mbit/s with iwconfig, you're hooked up correctly. :-)

LED doesn't turn on

Wireless works fine, but the wireless LED indicator get never turned on

  • I've got another problem, it turns on for me but with wpa_supplicant the LED is always blinking. I'm using this to switch it to constant light (but the blinking reappears after a couple hours):
 echo 255 > /sys/class/leds/iwl-phy2::radio/brightness

--Pflanze2 12:39, 11 October 2009 (UTC)

I've now solved it by patching the driver, see --Pflanze2 14:51, 11 October 2009 (UTC)