Talk:Qualcomm Gobi 2000

From ThinkWiki
Revision as of 22:00, 21 August 2010 by Aneiser (Talk | contribs) (2.6.32, 2.6.34, git snapshots and later)

Jump to: navigation, search

Firmware

I found out a way to get the firmware on a linux-only system. Mine is a debian squeeze, but it should apply to any system.

First, I entered my model number on the Lenovo support page in the right siderow (Select you system / Quick Path) to get to my drivers page. There I clicked to download drivers and on the UMTS drivers. Afterwards I downloaded the "7xwc42ww.exe" driver package.

With wine I was able to install the driver package, but all it does, was unpacking the GOBI driver setup. This one comes packaged as a .msi file, so we have to unpack it:

user@machine:~$ wine msiexec /a ~/.wine/drive_c/DRIVERS/WWANQL/Driver/GobiInstaller.msi TARGETDIR=C:\\DRIVERS\\GOBI

The installer quits with errors, but leaves the files on the disk, success. But now there are several subdirectories, in which the files for the specific network operators reside:

Dir Image Remarks
0 Vodafone Image
1 Verizon Image
2 ATT Image
3 Sprint Image includes special Firmware
4 T-Mobile Image
6 Generic UMTS Image
7 Telefonica Image
8 Telecom Italia Image
9 Orange Image
12 DoCoMo Image includes special Firmware
UMTS Default Firmware the MD5-sum on the page matches these

t

I found this out by reading the ReadMe.rtf, looking into the UQCN.mbn-Files and apply a little bit of thinking.

Now I'll move the files over and try them out.


So I got the Sprint Image with firmware, how does one flash the Gobi with this firmware?

You do not need to flash the gobi as such. Firmware must be loaded at every boot. Simply use the gobi_loader mentioned on the main page, with the 3 firmware files from the sprint directory. You will need to modify it to match your USB IDs. After the firmware it loaded it will last until you power off your laptop. I usually reboot after loading the firmware, but before trying to use the modem. The firmware remains loaded. Catphish

-- I appear to have got the WWAN portion functioning but can't find any reference to anyone using the GPS part. Does this work under Linux yet? Bjb

For me this images work with eplus germany --Lynxis 23:13, 8 June 2010 (UTC)

84d002b0ef003cde6c95826bfbf067fe  /lib/firmware/gobi/amss.mbn
d7496085f1af3d1bfdf0fa60c3222766  /lib/firmware/gobi/apps.mbn
c3d6fd93ae2e52775ef9cd8fccbc20be  /lib/firmware/gobi/UQCN.mbn


$ find -type f -exec md5sum {} \; | sort -k 2
c3d6fd93ae2e52775ef9cd8fccbc20be  ./0/UQCN.mbn
4d6203bf9fe8ae1af439d4d163e91596  ./12/amss.mbn
385a22740f80c0d00f8acdd9ad637032  ./12/apps.mbn
e868df00bfa88596d588a52f872ff703  ./12/UQCN.mbn
48191d62dc4091fb9d23e0b947611c58  ./1/amss.mbn
4f46a856fcceb197943d0cf3257c3621  ./1/apps.mbn
bb05d912e27b822348d4de93fc3ac911  ./1/UQCN.mbn
ff935ec4da6f6711b48caaddcf737566  ./2/UQCN.mbn
4f74d79ed8df027db3b75e36feb2bd27  ./3/amss.mbn
d9ff7b27c491332650b1efbbee64ee31  ./3/apps.mbn
6f6462fe0cc185cc3dc24720a28770fb  ./3/UQCN.mbn
46418504e70971bda7b2ee34cc80b5b7  ./4/UQCN.mbn
1aa5727b034dd1f371a3412d5800c1a3  ./6/UQCN.mbn
9f6773625d59098f9360c24263d99615  ./7/UQCN.mbn
e012286117c0c7708369f8dbc7906e64  ./8/UQCN.mbn
c65246da47695b4ecaaf098a02718c9d  ./9/UQCN.mbn
84d002b0ef003cde6c95826bfbf067fe  ./UMTS/amss.mbn
d7496085f1af3d1bfdf0fa60c3222766  ./UMTS/apps.mbn

For me this tutorial above worked, too. Is there anything which prevents us from copying it to the page itself? --Aneiser 20:58, 21 August 2010 (UTC)

2.6.32, 2.6.34, git snapshots and later

so it's working with recent kernels or no? And add any info about GPS, please. Tensai.cirno 02:26, 16 June 2010 (UTC)

I had no luck with 2.6.34. however i tested 2.6.35-rc3 + gobi_loader 0.6 and it worked. had to load the firmware by hand though ... "/lib/udev/gobi_loader -2000 /dev/ttyUSB0 /lib/firmware/gobi" but i guess the id in the udev file is not the right one for my card. --Max p 02:09, 22 June 2010 (UTC)

Thanks a lot, this is very good news. Tensai.cirno 06:54, 23 June 2010 (UTC)

Yes, with 2.6.35 and gobi_loader 0.7 it works for me (T510, O2 Germany, Generic firmware) --Aneiser 21:00, 21 August 2010 (UTC)

GPS

Has anyone managed to get GPS to work yet? I think one has to send certain AT commands to receive the NMEA information (at least that is how it works with some Ericsson modems). Unfortunately I can't find an AT command reference for the Qualcomm Gobi 2000 ... Flyser 14:15, 27 July 2010 (UTC)

i was asking the qualcomm support about that subject, handing out all AT commands. lets say it that way they were not very cooperative. but you could ask them as well, maybe you got more effective than me and we can have the commands :)--Max p 09:10, 4 August 2010 (UTC)

so did I. I was told to contact Lenovo about the issue -.- --Flyser 08:10, 9 August 2010 (UTC)

You can find the documentation and sdk here. However I didn't find any useful AT commands, and I think the SDK is win only. bbandi 22:32, 14 August 2010 (UTC)