Talk:Problem with non-ThinkPad hard disks

From ThinkWiki
Revision as of 22:04, 28 March 2007 by YuvalKashtan (Talk | contribs) (HTS721080G9AT00)

Jump to: navigation, search

I replaced my R52's Hard disk by ST9100823A 100G/5400, when the system stared, it shows error information.

How could I solve the problem, if you know, please email to me wangdongmail@hotmail.com

Thanks

Downgrade the BIOS to v1.01

To the poster ("TellIT systems"?): can you explain what is the "BUG" in later versions? What is the source of this information?

Can anyone report his experience with the BIOS downgrade?

--Thinker 22:05, 26 Nov 2005 (CET)


It seems he is talking, not about the BIOS for entry model R52/T43 models, but about the embedded-controller (EC) firmware.

As such the download link is wrong.

And yes, what is the bug that requires you to downgrade the EC firmware? Without more detail, I would be inclined to remove it.

--Tonko 02:34, 27 Nov 2005 (CET)

I looked around the German website a bit, and found this document: http://www.tell-it.ch/harddisk.php

It does not explain anything more. As such I think the prudent thing to do is NOT backlevel your firmware, but to wait until we either have more details, or an official firmware update from Lenovo.

I will remove the Downgrade Bios piece from the main page as it is clearly wrong anyway in its current form.

--Tonko 02:45, 27 Nov 2005 (CET)


Tonko, the ancient version numbers fooled me too, but the IBM page he links to is about R52 BIOS firmware, not EC firmware. It's plausible that BIOS 1.01 didn't yet include the disk detection code, so maybe the downgrade will indeed silence the warnings. I updated the description to reflect this. Of course, the story about a "bug" is probably wrong -- if test was deliberately introduced due to broken hardware, it is unlikely to be removed in future versions.

--Thinker 20:13, 27 Nov 2005 (CET)


Thinker, the download page he linked to, also applies to T43 entry-models.

He was saying to downgrade the BIOS from 1.03 to 1.01, but the latest BIOS is actually at 1.20, while the EC firmware is currently at 1.03, which made me think he was not talking about a BIOS downgrade, but an EC downgrade.

In any case, without more details I would strongly suggest not to downgrade your firmware as it may possibly break things. BIOS and EC for instance need to be matched typically, and it is possible that newer machines are not compatible with these older firmware releases (not sure if the flash tool will allow you to flash that far back in that case or not).

--Tonko 17:08, 28 Nov 2005 (CET)


Agreed. Maybe the downgrade instructions date back to when BIOS 1.03 and T43 model 1xxx were the latest versions; they sure don't look good now.

--Thinker 17:21, 28 Nov 2005 (CET)


Tell IT systems comment: The Problem anyway has solved this way - without any failures. A newer BIOS Upgrade is yet available now: Original Text of the description: "A new BIOS setup option, that allows system startup without pressing the ESC key on POST 2010 warning message. Its location is 'BIOS Setup menu'->'Startup'->'Boot after message for Hard drive...'. Note: The cause of the 2010 message is using unsupported hard drive firmware version. Please use supported version as much as you can."

Not nice to see that IBM/Lenovo does no more support the industral standard..


To Tell IT systems: Thanks for sharing your solution, but when posting to the Wiki please respect the existing content and organization. About the new BIOS, there are already a couple of references to the new BIOS higher up in the article, so there's no need to repeat that. About the suggested BIOS downgrade, do you mean the BIOS firmware or the Embedded Controller firmware? The versions number you posted seem to match the Embedded Firmware, which has nothing to do with that message. The latest versions of the BIOS are 1.2x, not 1.0x. Also, how can you be sure that the error message is bug, rather than a warning about a true hardware problem?

--Thinker 19:17, 6 Dec 2005 (CET)


I've update my T43 EC to 1.04 and BIOS to 1.24, although it really has an option in the BIOS that allow the system to boot when ERROR 2010.

However, I found that it really has a compatibility problem with my new Seagate 80 HDD (ST9809211A).

Poor.....

--ecowalker 23:38:17, 17 Jan 2006 (GMT+8)


Seagate Momentus 7200.1

Comments by Jbaldini:

SUBMITTED September 1st, 2006

I can only speak for the Seagate Momentus 7200.1 ST910021A (100GB 7200RPM) listed above.

It does NOT work out of the box, and all serials have the same firmware 1.03 from Seagate (I called them). No user has reported this drive to work and users have reported that it gives the error after the IBM firmware to get it up to version 1.07. I also upgraded the firmware manually with IBM's util which you have to do because it only automatically updates if the drive contains an older "IBM" version of the firwmare. Of course with no help from the directions below or Seagate support, just upgraded the firmware based on running the Seagate util and see it's parameters listed. To upgrade the IBM firmware the directions given on the link at the bottom were also wrong applying to the Seagate drives. But there is no need to upgrade that drive with IBM's firm.

This drive will always cause the error for every person on one of the laptops, I bought when because this create hope and the WARNING is inaccurate as I mentioned since they all have 1.03 "out of the box" which doesn't work. Seagate knows it doesn't work.

I also performed a low level format, took between 9 and 11 hours, still didn't work. Just wanted to make sure. Do not buy this drive for those laptops. I'm going to down grade the R52 BIOS since there are no reported problems running any ATA drive in a system like this using a SATA to PATA bridge but I'll be using a different drive. Not the 150 dollar momentus.

Hope this helps some people not make the same mistake I did. I strongly caution against purchasing any momentus for these laptops based on this experience.

Thanks,

J

UPDATE***** September 1st, 2006 Just downgraded the BIOS, not sure the limitation but it won't boot the 100GB Seagate Momentus but boots the 30GB travelstar fine which has always worked so downgraded BIOS has either drive or boot partition limitation, I really don't care which, I'm loading the new BIOS again since this downgrading was a stupid idea (by the way, Seagate recommended too) but it doesn't work for this drive. I have to say IBM or Lenovo has really disappointed on this I used to think (no pun intended) Thinkpad were solid, and it's only these goofball models, who would use a pata to sata bridge ???? just require a fricken serial 2.5 drive or use an PATA interface. Good thing I got this craptop for free.

J


HTS721080G9AT00

It seems there is a working solution for this module:

1. Download the now well known bootable hard drive firmware CD from Lenovo - I used revision fwhd44 (fwhd44.iso): http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-62282 2. Boot from that CD after you burned it 3. Exit to the DOS prompt. 4. Type: (changing the letter I to a letter O essentially) Code: copy MC4IA51A.bdr MC4OA51A.bdr

5. Type: Code: hfui15.exe OA51A MC41IA51.bdr /F mpcA5IAb.tbl

6. Hit "U" in the flash program to start 7. After you get the FAIL message, hit a key to return to the DOS prompt 8. Type: Code: hfui15.exe IA51A MC41IA51.bdr /F mpcA5IAb.tbl

9. Hit "U" in the flash program to start 10. You should get a PASS this time and be all set.