Talk:Problem with LCD brightness buttons

From ThinkWiki
Revision as of 09:43, 13 October 2007 by WilliamPoetra (Talk | contribs) (Problem with LCD brightness buttons after suspend-to-ram)

Jump to: navigation, search

Problem with LCD brightness buttons after suspend-to-ram

On my X60 1706-BM7, it's possible to suspend-to-ram either using s2ram or just "echo mem > /sys/power/state". There's a problem I've noticed, that after I resumed the machine, the LCD brightness buttons take longer to respond. Symptoms are:

  • Before suspending, whenever I press the LCD brightness up/down keys, the screen promptly respond by dimming or brighten up.
  • After resuming, whenever I press the same keys again, it takes about 1 sec. for the screen to dim or brighten up.
  • After resuming, if I use the command "echo down > /proc/acpi/ibm/brightness" or "echo up > /proc/acpi/ibm/brightness", the screen will respond right away, just like before suspending.
  • Without suspending, using "vbetool post" doesn't give this behaviour.

So I think this problem is related to the buttons itself. Does anyone have a similar experience? Any solutions? --WilliamPoetra 10:55, 25 March 2007 (CST)

Edit: According to Sebastian Schmidt, the delay goes away with BIOS 2.11 [1]. I'll check it out.

Can't change brightness on T61

I'm using a T61 with linux kernel 2.6.21-5 and thinkpad-acpi module v.0.14. For the life of me I can't manage to change the LCD brightness. I've tried using both the thinkpad-acpi method under /proc/acpi/ibm/brightness and also the kernel acpi video method under /proc/acpi/video/VID/LCD0/brightness, but neither works. Nor do the Fn-Home and Fn-End keys work themselves.

X Reboot after changing brightness beyond limit X60

I am running Ubuntu Feisty $ uname -r 2.6.20-16-generic on an X60 1706-85G BIOS update is from May 2007

After pressing the brightness up or down keys serveral times and passing the max low/high brightness limits the X server reboots:

$ tail /var/log/syslog Jul 18 07:23:11 brasov gdm[6387]: gdm_slave_xioerror_handler: Schwerwiegender X-Fehler - :0 wird neu gestartet

When I rmmod the video module as suggested the brightness keys do not work at all.

In the Ubuntu boot splash screen the brightness keys work normally.

Any suggestions?