Difference between revisions of "Talk:Installing Ubuntu 6.10 (Edgy Eft) on a ThinkPad T60"

From ThinkWiki
Jump to: navigation, search
m (Power Management Issues)
(Power Management Issues)
Line 70: Line 70:
 
[[User:Mgrusin|Mgrusin]] 18:44, 30 December 2006 (CET)
 
[[User:Mgrusin|Mgrusin]] 18:44, 30 December 2006 (CET)
  
 +
'''UPDATE''': I got suspend (but NOT hibernate) to work by following the instructions in this ubuntuforums thread: http://www.ubuntuforums.org/showthread.php?t=274511.  Briefly powernowd needs to be stopped before suspend and restarted afterwards.  Still researching hibernate problems (I'm hoping that better solutions make it into future base distros and packages).  Also, thanks McGiver for the explanation of suspend (below).
 +
 +
[[User:Mgrusin|Mgrusin]] 19:37, 10 January 2007 (CET)
 
----
 
----
  

Revision as of 19:37, 10 January 2007

Lost logout shutdown/restart options after Beryl [FIXED]

When I installed beryl using the instructions on this page, everything worked great (thanks!) except I lost the shutdown and restart options on the logout screen. This seems to be a common problem re. this thread at ubuntu forums: http://ubuntuforums.org/showthread.php?p=1947679#post1947679.

From advice in that thread I changed my /usr/local/bin/startxgl.sh to this:

#!/bin/sh
Xgl -fullscreen :1 -ac -br -accel glx:pbuffer -accel xv:pbuffer &
sleep 4
export DISPLAY=:1
cookie="$(xauth -i nextract - :0 | cut -d ' ' -f 9)"
xauth -i add :1 . "$cookie"
exec gnome-session

...which got the shutdown and restart options back for me. You might consider adding this to the instructions if it's not too much of a hack.

Thanks very much for this guide! Mgrusin 18:44, 30 December 2006 (CET)


Thanks, worked for me too! I've modified the tutorial accordingly. Keithvassallo 22:50, 02 January 2007 (CET)

Power Management Issues

Hi there,

Is anyone having problems with Suspend to Disk? It's suddenly stopped working for me...

Keith



Re: Problems with Suspend to Disk


What problems exactly?

-freeze while suspending or

-freeze on wake up

-doesn't do anything if you press the suspend key combination

My Keyboard Suspend shortcuts stop working if I don't login with gnome, because the acpi_fakekey script launched doesn't work outside of gnome.

pmi action sleep 

and

pmi action hibernate

should work

Roland (McGiver)


Well,

The problem I'm having is that suspend to RAM only works sometimes - the other times it just crashes. Suspend to disk just doesn't work - just crashes all the time.

What script are you using? I'm just using FN+F4 and FN+F12, or right-clicking on the power manager and selecting Suspend or Hibernate.

Keith


I'm having suspend / hibernate problems but it's not "suddenly" since this is a fresh install (edgy 6.10, T60p). My symptoms are upon suspend/hibernate, the screen goes black and the moon LED starts blinking but never stops. It won't wake up from this state without a hard shutdown.

I've been trying many suggestions over at ubuntu forums but haven't found the key yet. Most likely in my mind is upgrading from fglrx driver 8.28 to 8.30+, but I can't find that version in synaptic yet and don't want to mess with compiling it myself.

Mgrusin 18:44, 30 December 2006 (CET)

UPDATE: I got suspend (but NOT hibernate) to work by following the instructions in this ubuntuforums thread: http://www.ubuntuforums.org/showthread.php?t=274511. Briefly powernowd needs to be stopped before suspend and restarted afterwards. Still researching hibernate problems (I'm hoping that better solutions make it into future base distros and packages). Also, thanks McGiver for the explanation of suspend (below).

Mgrusin 19:37, 10 January 2007 (CET)


I'm having the exact problem as Mgrusin. Using PMI doesn't work either. I do think the issue is related to fglrx drivers. I'm going to wait for the new version though. According to several tutorials, using suspend2 seems to solve the suspend to disk issue. However, I had tried that with an earlier Ubuntu installation and bricked it, so I'm not trying again!

Keithvassallo 23:09, 02 January 2007 (CET)


Maybe some of the scripts in /etc/acpi/suspend.d prevent your system from suspending.

if you don't know how how Suspend to Ram in Ubuntu works read the following lines (else jump forward to Finding problems)

How Suspend in Ubuntu works (light version):

however you prefer to suspend in Ubuntu, all ways will lead to

/etc/acpi/sleep.sh force

first of all speep.sh will get some Varables (about screen lock, power management,...) by calling

/etc/default/acpi-support
/usr/share/acpi-support/power-funcs
/usr/share/acpi-support/device-funcs
/usr/share/acpi-support/policy-funcs

afterwards

/etc/acpi/prepare.sh

will execute all scripts (*.sh) in

/etc/acpi/suspend.d

and then suspend with

echo -n $ACPI_SLEEP_MODE >/sys/power/state

($ACPI_SLEEP_MODE is "mem" in case of suspend to Ram)

Your notebook is now suspended.

Waking up works similar:

/etc/acpi/resume.sh

calls all scripts (*.sh) in

/etc/acpi/resume.d


Finding problems:

disconnect all USB Storage media and try a simple

echo -n "mem" > /sys/power/state

(wake up by pressing fn or closing and reopening the display)

if that works

backup all the scripts in /etc/acpi/suspend.d (and /etc/acpi/resume.d) and remove them.

Then try suspending with your fn keys or

pmi action sleep

if that works too, copy back the scripts one by one, trying if suspend still works

(of course you could also test the scripts one by one and see which one doesn't work)

McGiver 16:06, 04 January 2007 (GMT+1)

Problems with ALt-Gr

My Alt-Gr key doesn't work in Beryl. I think it's a problem with loading the right keymap.

my solution is a small workaround: loading your preferred keymap with gnome, by adding the following script (save in /usr/bin/restorekeymap) to gnome startup programs

#!/bin/bash
setxkbmap -model pc105 -layout de -variant nodeadkeys
#if you use the .Xmodmap file for other stuff too uncomment the following line
#xmodmap .Xmodmap

Replace keymap model, layout and variant with the one you prefer.

Please let me know if there's a better Solution

Roland (McGiver)


Video in Beryl

anyone else suffering under extremely slow video in Beryl? All Video players seem to require much more resources in Beryl. Anyone else experiencing the same Problem?

Kaffeine(Xine) slows down the whole system (on my 1.7GHz Banias) and sometimes kaffeine freezes. Mplayer works better, but still keeps the cpu usage on ~90% on fullscreen.

Doing something with tpb OSD makes it even worse. Changing volume in many cases permanently freezes kaffeine, and results in temporary 1fps in mplayer.

I tried all available Video output Plugins (xv, opengl,...) without noticing a difference.

Roland (McGiver)