Difference between revisions of "Installing Ubuntu 7.10 (Gutsy Gibbon) Tribe 3 on a ThinkPad T61"

From ThinkWiki
Jump to: navigation, search
(Updates)
 
(9 intermediate revisions by 5 users not shown)
Line 1: Line 1:
===Opening Notes:===
+
#REDIRECT [[Installing Ubuntu 7.10 (Gutsy Gibbon) on a ThinkPad T61]]
 
+
1) This is written for Tribe 3, as development moves forward many of the items listed here will (hopefully) no longer be necessary or no longer apply.
+
 
+
2) Use the Alternative Installer, the Desktop installer installs but fails to boot
+
 
+
3) While Gutsy has been relatively stable lately if you are looking for stability stay with Feisty.
+
 
+
 
+
 
+
===Hard Disk Controller===
+
When the system boots hit F1 to enter the Bios, select Config->Serial ATA (SATA) and set the SATA Controller mode option to "Compatibility".
+
 
+
{{NOTE|With each new Kernel release this process must be repeated}}
+
 
+
 
+
===Video:===
+
 
+
====Intel:====
+
Must install using the alternate CD or the regular CD and hit F4 to change VGA settings to 1024x768x32 and use regular install.
+
 
+
Starting with Tribe 3 on the T61, Ubuntu defaults to using the Intel driver.
+
 
+
====Nvidia:====
+
 
+
As of July 10th the latest nv 2D driver was released that supports the 140m in the T61 and this driver is in Tribe3.
+
 
+
If you would like 3D acceleration then you must download and install the proprietary drivers from Nvidia here:
+
http://www.nvidia.com/object/unix.html
+
 
+
To install these drivers:
+
 
+
1) install build-essentials from Synaptic
+
 
+
2) Download the drivers from the link above to your home directory
+
 
+
3) When the download completes hit Ctrl-ALT-F1 to drop to a console. 
+
 
+
4) Login and type:
+
 
+
{{cmdroot|sudo /etc/init.d/gdm stop}}
+
 
+
{{cmdroot|sudo sh NVIDIA-Linux-x86-100.14.11-pkg1.run}}
+
 
+
If the file you download is newer that 100.14.11 make sure you modify the command appropriately
+
 
+
When asked permit the installer to modify your xorg.conf
+
 
+
Reboot:
+
{{cmdroot|sudo shutdown -r now}}
+
 
+
{{NOTE|With each new Kernel release this process must be repeated except you should tell the installer to not update xorg.conf}}
+
 
+
===Wireless:===
+
 
+
====Thinkpad 11A/B/G====
+
The Atheros card works with the Madwifi driver included as part of the Restricted-Modules package in Gutsy and should be installed by default
+
 
+
 
+
====Intel IWL4965 A/G/N====
+
As of July 26th the IWL4965 driver and firmware is included in linux-ubuntu-modules-2.6.22 which should be installed by default.
+
https://lists.ubuntu.com/archives/gutsy-changes/2007-July/005258.html
+
 
+
 
+
 
+
===Audio:===
+
 
+
Audio does not work out of the box, download and install the latest version of Alsa from CVS using the instructions here:
+
http://alsa.opensrc.org/index.php/Quick_Install
+
 
+
==References==
+
* This guide is listed at the [http://tuxmobil.org/ibm.html TuxMobil Linux laptop and notebook installation guides survey (IBM/Lenovo)].
+
 
+
 
+
==Updates==
+
 
+
 
+
{{NOTE|The section below is optional}}
+
 
+
 
+
 
+
====IWL4965====
+
As of July 27th Ubuntu ships version 0.42 of the iwlwifi driver, if you would like to install version 1.0 follow the instructions below:
+
 
+
{{NOTE|As the release process moves forward the Kernel will be updated so make sure to update the paths below}}
+
 
+
{{NOTE|With each new Kernel release this process must be repeated}}
+
 
+
Install the necessary prerequisites and get the directories symlinked right.
+
 
+
sudo apt-get install build-essential linux-headers-`uname -r`
+
sudo ln -s /usr/src/linux-headers-`uname -r` /lib/modules/`uname -r`/source
+
 
+
Download and install the latest mac80211 from the 8.x.x branch.  8.0.2 is the latest as of this edit.  The 9.x.x branch is currently experimental.
+
 
+
wget http://intellinuxwireless.org/mac80211/downloads/mac80211-8.0.2.tgz
+
tar -xzf mac80211-8.0.2.tgz
+
cd mac80211-8.0.2/
+
sudo make patch_kernel
+
cd ..
+
 
+
Download and install the latest iwlwifi from the 1.0.x branch.  1.0.0 is the latest as of this edit.  The 0.1.x branch is currently experimental, but is necessary if you need to use 802.11n.  These instructions may or may not work if you want to use 0.1.x.
+
 
+
wget http://intellinuxwireless.org/iwlwifi/downloads/iwlwifi-1.0.0.tgz
+
tar -xzf iwlwifi-1.0.0.tgz
+
cd iwlwifi-1.0.0/
+
make
+
sudo make install
+
cd ..
+
 
+
Download and install the latest 4965 ucode.
+
 
+
wget http://intellinuxwireless.org/iwlwifi/downloads/iwlwifi-4965-ucode-4.44.17.tgz
+
tar -xzf iwlwifi-4965-ucode-4.44.17.tgz
+
cd iwlwifi-4965-ucode-4.44.17/
+
sudo cp iwlwifi-4965.ucode /lib/firmware/`uname -r`
+
 
+
Make sure the hardware wifi switch is on before doing this.
+
 
+
sudo modprobe iwl4965
+
 
+
After that, you should simply be able to connect to wireless networks using Gnome's network manager.
+
 
+
 
+
{{T61}}
+

Latest revision as of 12:37, 3 November 2016