E14 hardware tweaks

From ThinkWiki
Revision as of 05:17, 18 May 2020 by Teleshoes (Talk | contribs)

Jump to: navigation, search

TODO: miscellaneous hardware notes for a conscientious editor to organize


my setup:

  • Intel i7-10510U CPU
  • No discrete graphics (AMD Radeon option is available)
  • linux 5.6.13
  • debian sid
  • xorg 1.20.8


CPU


RAM

  • only one slot! for god only knows why!
  • 16GB works fine


WIFI

RTL8822-CE

  • this is what it comes with
  • works just fine ootb on linux 5.6.13
  • observing wifi speeds 22MiB/s (against RT-AC68U running ddwrt)

Intel Wireless AX201

  • works, but ONLY on bios 1.11+
    • not detected in lspci OR lshw running BIOS 1.09
  • requires a kernel 5.2 or higher, and doesnt work on SOME 5.4 and 5.6 kernels
    • works on 5.6.13 kernel, BUT loads iwlwifi-QuZ-a0-hr-b0-48.ucode and lshw prints "Wireless-AC 9462" but it seems at least OK
    • observing wifi speeds around 70MiB/s (against RT-AC68U running ddwrt)


Graphics

  • works fine on linux 5.6.13
    • 1080p media playback is smooth
    • cuphead on steam proton runs smooth at 1920x1080
  • HDMI works
    • 4k media is smooth
    • 5.1 channel audio works correctly with pulse (hdmi profile is hdmi2, hdmi1 is usb-c)
  • BUG: observed occasional HORRIBLE flickering
    • every once in awhile, screen would start flickering to black every second or two
    • once it started, it would keep going like that until reboot
    • dmesg: drm:intel_cpu_fifo_underrun_irq_handler
    • i915.enable_rc6=0 on the linux cmdline fixed it, at least for the past 12 days
  • seems to require a 5.0+ kernel
    • hd graphics wouldnt load at all on a late 4.x kernel
    • cpu rendering worked fine, at 1280x720, but was ugly


NVME

Sabrent 4TB Rocket NVME M.2

  • works BEAUTIFULLY, 3634MB/s real world read speed, 3122MB/s real world write speed


SATA

Samsung 860 EVO 2TB 2.5" SATA 7mm

  • works great, 568MB/s read, 529MB/s write


LCD

IPS 250 nits

  • its ok

LEDs

  • Thinkpad (i) LED is unknown_led2 in thinkpad_acpi
  • power, green:batt and orange:batt, mute, and micmute all work

Fan

  • auto mode actually works well (fan is off most of the time, and quiet under moderate load, and loud as hell under heavy load)
  • thinkpad_acpi 0, 1, 2, and 3 all completely turn off the fan
  • thinkpad_acpi 4, 5, 6, and 7 all turn the fan to max