Talk:Problem with LCD brightness buttons

From ThinkWiki
Jump to: navigation, search

Problem with LCD brightness buttons after suspend-to-ram

On my X60 1706-BM7, it's possible to suspend-to-ram either using s2ram or just "echo mem > /sys/power/state". There's a problem I've noticed, that after I resumed the machine, the LCD brightness buttons take longer to respond. Symptoms are:

  • Before suspending, whenever I press the LCD brightness up/down keys, the screen promptly respond by dimming or brighten up.
  • After resuming, whenever I press the same keys again, it takes about 1 sec. for the screen to dim or brighten up.
  • After resuming, if I use the command "echo down > /proc/acpi/ibm/brightness" or "echo up > /proc/acpi/ibm/brightness", the screen will respond right away, just like before suspending.
  • Without suspending, using "vbetool post" doesn't give this behaviour.

So I think this problem is related to the buttons itself. Does anyone have a similar experience? Any solutions? --WilliamPoetra 10:55, 25 March 2007 (CST)

Edit: According to Sebastian Schmidt, the delay goes away with BIOS 2.11 [1]. I'll check it out.

Edit: Nope, the problem doesn't go away.

Edit: I have the same Problem on my T61.

Edit: The same is happening to me: R61 7733-1ES (Caio Romão)

Can't change brightness on T61

I'm using a T61 with linux kernel 2.6.21-5 and thinkpad-acpi module v.0.14. For the life of me I can't manage to change the LCD brightness. I've tried using both the thinkpad-acpi method under /proc/acpi/ibm/brightness and also the kernel acpi video method under /proc/acpi/video/VID/LCD0/brightness, but neither works. Nor do the Fn-Home and Fn-End keys work themselves.

X Reboot after changing brightness beyond limit X60

I am running Ubuntu Feisty $ uname -r 2.6.20-16-generic on an X60 1706-85G BIOS update is from May 2007

After pressing the brightness up or down keys serveral times and passing the max low/high brightness limits the X server reboots:

$ tail /var/log/syslog Jul 18 07:23:11 brasov gdm[6387]: gdm_slave_xioerror_handler: Schwerwiegender X-Fehler - :0 wird neu gestartet

When I rmmod the video module as suggested the brightness keys do not work at all.

In the Ubuntu boot splash screen the brightness keys work normally.

Any suggestions?


This might or might not be related to the above problems, but on my T61 (intel video) using Debian Lenny, the fn-home and fn-end keys do not change the screen brightness. Some digging around shows that these keys do change /proc/acpi/video/VID/LCD0/brightness, which does not appear to affect the screen at all, while manually sending something to /proc/acpi/video/VID1/LCD1/brightness (note the 1 after VID) does have an effect on the screen. Now my problem remains figuring out how to configure these keys to work. I'm not even sure which piece of software is controlling them at this point. Any hints?

VID vs VID simple solution

There is a simple solution for T61 computers that by default Fn+Home/End hot-keys will change /proc/acpi/video/VID/LCD0/brightness instead of VID1 that controls LCD.

For now you can add a file, named (optional, you can name it anything) "brightness_controll" to /etc/acpi/events and add these two lines into it

event=video LCD0
action=echo `cat /proc/acpi/video/VID/LCD0/brightness|grep current|cut -f 2 -d " " ` > /proc/acpi/video/VID1/LCD0/brightness

It will on event of LCD0 brightness change copy the brightness value LCD0 from VID to VID1. It will do the just for now.