Talk:Installing Ubuntu/Breezy on a ThinkPad T42

From ThinkWiki
Jump to: navigation, search

Why is it important to turn off dynamicClocks in radeonfb in kernels before 2.6.14?

What is wrong with the wireless on/off script that comes with Breezy and is mapped to Fn-F5 out of the box? Why replace it?

Why use noflushd when Breezy comes with laptop-mode? Just enable it in /etc/default/acpi-support.

Using Fn-F6 to enable/disable Bluetooth

First, to make sure Fn-F6 is available as a hotkey, either do

 echo 0xffff > /proc/acpi/ibm/hotkey

(this will work until next reboot or suspend), or change the mask in /etc/modprobe.d/ibm_acpi.modprobe.

Next, create a shell script /etc/acpi/

 # Enable/disable builtin Bluetooth on IBM Thinkpads
 if grep -q enabled /proc/acpi/ibm/bluetooth; then
     echo disable > /proc/acpi/ibm/bluetooth
     echo enable > /proc/acpi/ibm/bluetooth
     #sometimes the hcid won't recognize
     /etc/init.d/bluetooth restart

Next, create an event file /etc/acpi/events/ibm-bluetooth

 # This is called when the user presses Fn-F6 button and calls
 # /etc/acpi/ for further processing.
 event=ibm/hotkey HKEY 00000080 00001006

You might need to restart acpid for it to start working.

Maybe some answers!

As it seems it is no longer neccesary to turn off dynamicClocks in radeonfb. radeonfb previously had a the same bug as in Xorg, where dynamicClock locked up some maschines. For radeonfb this lock up came randomly.

xorg has fixed this bug from version 6.8.3... Ubuntu ships 6.8.2.. to bad!

Changing the script is because of the initially ipw2100 off. This is a software off, not handled by the script, which only handles the hardware on/off, therefore we have to turn it "on" in both hw and sw.

The laptop-mode included is old! It doesn't handle hdd powermanagement properly. Noflushd is very easy to install.

Instead of noflushd I suggest you use laptop-mode-tools which is newer and actually works.

Good idea with the bluetooth. Right now Breezy turns both blutooth and wireless on/off with Fn-F5.

3d openGL acceleration with Radeon 7500 and Xorg

Hi, with XFree86 direct rendering worked well for me. Any ideas why this isn't working with Xorg? I checked a few guides, but I found no bugs in my config, i also tried all depths and modules. Any Ideas? Maybe I overlooked something. A "it works here" would be enough for me to keep on trying, thanks, T.