Talk:How to make ACPI work

From ThinkWiki
Jump to: navigation, search
NOTE!
Please sign and date your posts, that is much easier than trying to track down on page history who wrote what!

Contents

X41 Woes

I have tried the referred patch (Suspend to RAM) with the latest stable kernel (2.6.12.2): Reboot after wakeup.

T22 Woes

Has anyone managed to get this working with a T22? The BIOS is upgraded, but it _never_ wakes up from sleep. Neither lid nor pwr button are noticed by the system.

--Are you in suspend2ram? This works fine for me. I think you have to enable it in BIOS.

Sound-after-suspend not working with Mandriva 2006

With Mandriva 2006, suspend/resume works with ACPI, but sound quits working. This happens with the T20 and T22. The recommended Mandriva trick of setting "RESTORE_SOUND=yes" in the "suspend" script doesn't solve this. Other suggestions? - MarkStosberg mark@summersault.com

Solutions

I had 2 different issues: - with my X21 I had to unload the alsa modules before suspend. - with my x23 I have to change the mixer settings to get it working again.

(I hope it will help)

CIFS

Hi all,

I have found out that if I use cifs to mount Samba shares, I get lots of problems with suspend/hibernate (the cifsd breaks the shutdown process). Maybe it would be good to warn about this.

Alex (alex at corcoles dot net)

Auto-wake on lid open - how to STOP?

Anybody have any idea how to stop the machine (a T43p) from automatically waking up on lid open? My /etc/acpi/events only has a lm_lid file which is commented out - it should do nothing, and there is no plain 'lid' event. Is lm_lid an event only activated when in laptop-mode?


That's a good question, but I have the opposite problem: my T43 (2687) won't wakeup from S3 (suspend-to-RAM) when I open the lid, which is exactly what yours do, and what I wanted mine to.

-- hmh 2006-03-24 11:59:00 UTC-0300


Yes, I have the same problem - this 'feature' is exhibited in both O/S's on my T43p... I tried everything I could think of to stop it (changing/deleting the acpi event handlers, etc). There does not seem to be any BIOS option to "wake up on lid open."

It has irritated me less over time; I find myself now using suspend if I don't want the feature, and sleep mode only if I anticipate that I will open it up and use. After all, suspend is pretty quick with 1 GB ram.

-- gsmenden 2006-03-27 19:36:55 EST


Just a note...the term "suspend" refers to both, suspending to RAM and suspending to disk, the counterpart to the "sleep" term is "hibernate". We should try to stay clear about this everywhere to avoid confusion.

Wyrfel 10:24, 29 March 2006 (CEST)


There is a /proc/acpi/wakeup file here. (t42p). Currently shows: Device Sleep state Status

 LID       3            * enabled
SLPB       3            * enabled
PCI0       3            disabled
UART       3            disabled
PCI1       4            disabled
USB0       3            disabled
USB1       3            disabled
AC9M       4            disabled

Echoing the 4 letter code toggles that device as a wakeup device.. ie: root# echo " LID" > /proc/acpi/wakeup root# cat /proc/acpi/wakeup Device Sleep state Status

LID       3            *disabled

Does that work for any of you guys? Nirik 23:15, 29 Mar 2006 (MST)


I encountered the same problem and echoing to /proc/acpi/wakeup made the LID, the SLPB and the UART disabled (on my T43 - no matter what I did). The syslog told me that it was due to the fact they all share the same ACPI GPE.

After reading much on ACPI and the kernel handling, I think the reason is that the kernel code activates all _PSW supporting devices (which includes the LID).

I wanted to refrain from altering kernel code so I modified the ACPI DSDT (funny). At first I changed the GPE for the LID so it won't share it with the UART and the SLBP (which I believe is the "FN" button). Then when I saw it worked, but I had to keep echoing "LID disable" to /proc/acpi/wakeup so I erased the _PSW and _PRW entirely from the control method of the _LID device.

Now my laptop only wakes up when "FN" is pressed. I can post the DSDT modification or elaborate on my solution if you please.

Mr DNME 11:00 3 May 2006 (UTC+0300)


I would like to see the solution posted --Irongrunty 18:56, 27 May 2010 (UTC)

R50e - suspend to ram with DRI on

Does anyone got this working? After resume the X do not refresh properly applications (the panel, application content and background).

ACPI completely broken on Thinkpad T20s

I removed T20 and T21 from the recommended list, since, their BIOS's don't support ACPI properly. In the Linux 2.6 kernels, multiple kacpid processes create a race condition, eating up CPU time until the machine eventually has to be rebooted.

For more information see Ibm-acpi discussion page

--Fialar 20:02, 18 January 2007 (CET)

ACPI Sleep kills ALSA sometimes

My T41, running 2.6.20 has an issue where ALSA will not work correctly after suspend to ram and suspend to disc. Apps like aplay work fine, but gstreamer based apps, and xine all freeze. Unloading and reloading the drivers does not rectify this. I have to restart the whole machine.

Personal tools
Namespaces

Variants
Actions
Navigation
Toolbox