Problem with video related system lockup II

From ThinkWiki
Revision as of 14:16, 26 January 2008 by Vrossum (Talk | contribs) (added r50p as affected)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Thinkpads with the ATI 9600 video chip used in R50p, T42 and T42p can cause lock-ups.

This happens after about two years of use.

Symptoms

Screen goes blank, requires hard reboot (power off-on) to get screen display. On boot may give one long, two short beeps POST code. Screen goes blank when laptop flexed, eg adjusting lid angle, squeezing around ultranav trackpad area, twisting, pressing on palmrest. POST code or screen blanking more prevalent after warm-up. Problem gets worse over time. Problem repeatable from first boot (bios) screen with tpad partially disassembled - hdd, ultrabay, extra ram, wifi removed, kb, palm rest removed, but connected. See http://www.technotaste.com/blog/thinkpad-t42-ati-radeon-9600-driver-and-the-blue-screen-of-death-bsod and http://forum.thinkpads.com/viewtopic.php?t=33952 for discussions of many similar symptoms.

Diagnosis

Bad or broken solder joint on graphics chip. The chip is a ball grid array (BGA) package mounted to the system board. The problem is likely caused by an intermittent connection to the system board due to one or more bad or broken solder joints connecting the BGA to the system board. Thermal and/or mechanical movement breaks the connection, crashing the chip, yielding a blank screen or the BSOD.

Solutions

  • Replace system board.
  • Reflow the solder on the graphics chip: Remove the system board, take it to a board house that can reflow the BGA package, reassemble, cross fingers, test. There are a number of videos showing the process on YouTube. One of them: http://www.youtube.com/watch?v=vR8L3B3eDr0
  • Place a supplement between the GPU Disipator and the keyboard metal, this will push the gpu to the systemboard, forcing a better contact. I placed about eight post-it's bended at the half. So far, so good. it works for me (eMaringolo). See it here: http://www.flickr.com/photos/emaringolo/373874916/

See Also

Problem with garbled screen