Talk:ThinkPad Dock II

From ThinkWiki
Jump to: navigation, search

Got it! Actually able to run six monitors without any conflicts. Life is good.

Hope I doing this right. Look up the definition of novice in the dictionary and you will find my picture. That said, I have an R52 ThinkPad, a ThinkPad Dock II with an ATI FireMV 2400 PCI 128M video card in the dock PCI slot. Card supports 4 monitors. Was told by a guy at work just plug it all in, install the card drivers, set up the configuration of the monitors in display properties and your good to go. Not so. Display properties only shows 2 monitors. None of the four outputs of the card have a signal. I want to ultimately be able to use 5 monitors, the four supported by the the ATI card and the display on the R-52. Got any ideas where I can get help with this? Thanks for any help anyone can give me.


I just installed a Nvidia Quadro NVS 50 PCI card in an attempt to add an additional monitor to my laptop (T41), and get 1920 x 1200 digital on my 24" widescreen. The Nvidia is not a dual monitor card, but I thought I would be able to use it as well as the laptop's existing card (ATI Mobility Radeon 7500). However the ATI card shows up in the hardware manager with the message "This device cannot start. (Code 10)". I then tried to enable the AGP as the primary video device in the BIOS (PCI was enabled). The on-board adapter came up, and the device manager listed no conflict, but the Nvidia would not come up as I tried to extend my desktop in display props. I got the message that I did not have admin rights to select the Nvidia, followed by messages that my drivers were not compatible with the newer version of Windows. I have never tried to use two monitors before, so I am not sure if it is feasible to have two video cards running at the same time. If this is possible, please let me know what I need to do, if it is not possible then I need to return the card and get one of your recommended ones.

TIA! Tony

Hi Tony, can't help you much, i'm afraid. I have had a Radeon 9200 PCI card in the dock for a while, using it under Win. I think setting the AGP bus as the primary one in the BIOS is the way you should go. I had troubles with my Windows not booting up at all anymore when i changed it to PCI and was sure that it was the ATI driver having problems.

I would try to get the most recent drivers from the NVidia homepage. Best try uninstalling your drivers and reinstalling them. You might also check if your card is supported by the OMEGA drivers (

Good luck, Wyrfel.


I'd just like to clarify that if I have a PCI video card installed in the dock and I put my ThinkPad (a T43) on the dock, I'll be able to use the display on the laptop and the external display through the PCI card in the dock at the same time for multi-monitor support. Is this correct?

Modify for compatibility?

I have an X41 Tablet on the way and am very disappointed that the only "Dock" available is more like a glorified port replicator. While I'm sure the X41 Tablet wouldn't fit on the Dock II, do you think it would be possible to remove the docking port from the plastic and connect it to the X41, or is it a different style connector? I would really appreciate audio jacks and a PCI slot. ^

I think it is possible (I may look into it, as I have X41 Tablet also), but I must inform you that audio jack connectors, or some audio cables inside dock are of really bad quality, making sound not very good. I wanted to use this audio jacks to connect to my audio system, but of degradation in quality (it is really bad), I still use jacks port in laptop itself. It may be also because of elevated electromagnetic radiation from some elemnts, like power supply, which are inducing some noise and other currents. Maybe it is just mine unit of course, because it have few other strange problems.

--Baryluk 02:45, 23 March 2012 (CET)

Who wrote this about the 1920 x 1200 on the dock II?

This is a very important subject to me since we used to buy a lot of T series Thinkpads but dont any longer because of the lack of support for the widescreen external DVI flat panels.

Who wrote this about the new driver from 8-11-05 - I have contacted IBM tech support (not Lenovo) and they have not heard such a thing and it is not listed - they have looked at the last video driver update to the T42p or T43p (I am looking for the 14" SXGA+ T42p model) with a dock II being able to drive externally 1920 x 1200 (UXGA+) WITHOUT an added PCI card. This would be NIRVANA for me.

Do you have anymore information about this driver and have you SEEN it work at all?

Thanks Dean

I have a ThinkPad R40 2722-C3M with ATI Mobility Radeon 7500. I recently connected to a new 24" 1920 x 1200 LCD but initially couldn't support widescreen resolution - I updated the video driver and it now drives the ThinkPad LCD with desktop extended onto the 24" at 1920 x 1200 res.



Hei Dean,

i do not have a 1920x1200 display, but i have a 1600x1200 one which was unsupported before as well. The newest driver (upgraded via IBM Software Installer) indeed doesn't have the problem anymore which it had before with that resolution (1280x1024 was supported max). The newest Presentation Director supports the higher resolution as well.

I actually switched back from OMEGA drivers to the newest IBM release and experienced some strange behaviour which was gone after a few reboots). I guess some parts of OMEGA were not properly uninstalled in one go.

IBM might not know about this if they just upgraded the underlying Catalyst drivers.

However, you might wanna get a confirmation from someone using 1920x1200 before you celebrate. ;-)

Wyrfel 01:16, 4 Oct 2005 (CEST)

BTW: I merged the information that was provided here on this issue into the Problem with DVI throughput page, since it was doubled in several places and belongs there. Wyrfel 01:48, 4 Oct 2005 (CEST)

newest drivers work with high resolution via DVI

The above is a true statement. I have in Nov 2005 installed 3 Thinkpad T's (T42p and T43p) with 128 megs of ATI video RAM (Fire 3200) and with the Think Dock II using the pass through DVI port, i am driving Dell 20" WSXGA+ (1600 x 1050 widescreen) and Sony WUXGA (1900 x 1200) 23" widescreen flat panels. They work OUT OF THE BOX without having to install special drivers. This is a new feature of the Thinkpad line (at least for the T series).

Low Profile PCI? IBM says Half size.

I don't think that LowProfile PCI-Cards will fit in the Dock II cause of the shorter mounting bracket. I just successfully plugged a standard PCI card with the dimension 17.5 cm (without brackets and vga connector) x 9,9 cm (without pci connector, 10,7 cm with pci connector) This seems to be the maximum dimensions possible...think the 'half size' written by ibm means the length of the card, not the width, as there are full size pci cards e.g. for video editing that reach all the way to the front through a standard tower case.

Afaik 'half size' means the length of the card. For low profile there should be mounting brackets available making them fit - however as always: check before you invest money. --Low 08:20, 13 January 2009 (CET)

Z60 and T60

These machines are not supported by the legacy docks, you need to use the new Z60 range of port replicators and docking stations.

--Tonko 20:22, 11 Jan 2006 (CET)

T60 And Dual Monitors

Yes, you can drive dual monitors with the ThinkPad Advanced Mini-Dock. I am running it under Windows Vista and it is great! The thing you need to do is download the ATI drivers from Lenovo and use the Catalyst Control center to disable your laptop LCD and then enable your analog monitor. By default, the DVI is enabled if both monitors are plugged in.

--Paul317 22:30, 19 July 2007 (UTC)

So I can drive dual monitors with a T60 and an "THINKPAD ADVANCED MINI-DOCK"?

-- ryan 18:30, 18 April 2006 (CMT)

The docking solutions are listed here, and indeed that includes the ThinkPad Advanced Mini Dock which supports the T60.

You should be able to do any of the following:

  • ThinkPad LCD + Analog external monitor (VGA)
  • ThinkPad LCD + Digital external monitor (DVI)
  • Analog external monitor (VGA) + Digital external monitor (DVI)

DVI requires that you have a Dock or Port-Replicator for your ThinkPad with a DVI passthrough port on it.

--Tonko 22:59, 19 April 2006 (CEST)

Eject mechanism on Dock II

I've just acquired a used Dock II, and the eject mechanism seems to be a bit different from other Thinkpad docks and port replicators I'm familiar with. In particular, my question concerns the the square plugs on the dock base that help eject the laptop when the eject button is pressed. On the original dock for the A and T series, the original Port Replicator, and the newer Mini-Dock, the plugs are normally flush with the base, and are pushed up when the user presses the eject button. On the Docking Station II that I have, the plugs are spring loaded, are extruded from the base when no laptop is present, and are not affected by pressing the the eject button. That is, on the Docking Station II, the plugs are always applying pressure pushing the laptop up, and the laptop is held in place by the locking mechanism that is released when the eject button is pressed. Is this normal for the Docking Station II, or is there some linkage in my unit that's broken?

TIA, Sanford

This is perfectly normal and maybe was an attempt from IBM to reduce the complex mechanics of the eject mechanism of the older docks.

--BDKMPSS 15:31, 11 July 2008 (CEST)

R30, R31, and R32 are not supported

According to Docking station, port replicator, and expansion - ThinkPad General R30, R31, and R32 are not supported by ThinkPad Dock II.

Replace/unplug the noisy fan of Dock II

In the information page, it is said some user might replace or unplug the noisy fan, I attempt to open the Dock II so that I could reach the fan and do something about it, does some one here knows the steps to disassemble it? The noise of the fan is really LOUD!

Thanks ahead.

Help pleas

Does there exist a framebuffer driver that will create /dev/fb0 for the built-in video card and /dev/fb1 for the dock's PCI card allowing you to use both? Just like how modprobing radeon creates /dev/dri/card0 and /dev/dri/card1? All framebuffer drivers I've seen assume they will be used on only the boot display device. EDIT: When the AGP is the primary device, radeonfb will not create an fb on the secondary device. However when the PCI is the primary device, aty128fb will create an fb on the secondary device. The only problem is when the LCD is not the primary, everything on it is invisible. Starting X on it works but shows nothing, moving consoles to it works but shows nothing, etc.

These have been moved from the main page...

Dock II Linux users: can anybody recommend kernel modules and parameters for using PCI video cards with the dock's PCI slot? I had it working once with the dock, pci_slot, pci_hotplug and acpiphp modules and the pci=assign-busses parameter but since an unknown change to my system occurred, combinations of the above are no longer sufficient.

Dock II owners: anybody tried to shoehorn a larger card in?

Sorry for cluttering up the article (with the upper question). I've asked on the forums and mailing list. So far the LKML has given me the most help but the patch they recommended didn't solve the problem when I recompiled the kernel. However I thought the article should have some mention of this problem as it is likely to be the first stop for people who wonder whether or not they can use the PCI slot for a video card in Linux. Every single time I have seen a video card stated to be compatible with this dock, the person saying this was either a Windows user or didn't specify which OS he or she used. So unless someone DOES have this working (I had it working for a few days before it broke) we should probably say that the exact steps for getting docked PCI video cards to work in Linux are unknown. EDIT: It's working again without pci=assign-busses. This was either a BIOS or distro problem. I reset the BIOS to defaults and rolled back my packages and config files and reupdated one at a time instead of all at once. So I have this working now. Connor Behan 06:10, 13 January 2009 (CET)

Hotplug in linux


is there any exprience and guidlines about using this dock in T43 under Linux. I am interested in SATA controler, and was thinking how well it will take pluging and unpluging laptop. I would like to safely eject laptop from it, without demaging Dock, PCI card (and connected hard disks) or laptop. I guess, unmounting file systems, disabling block devices, removing drivers, and doing some poweroff to the Dock's PCI bridge would do the trick. But it may not be so simple. Also when plugining in, is everything autodetected, or needs some manual commands? --Baryluk 19:23, 3 September 2011 (CEST)

I have never had a dock with PCI integrated, but as far as I know all you should have to do is umount the filesystems and wait a second or two for the buffers to get flushed. Everything else *should* handle hotplug just fine. Certainly you should not be able to damage the hardware as it was designed as a hotplug solution, as long as it allows you to unplug ;-) Personally I would test it with a HDD without important data first to make sure your not causing corruption.

You can also write scripts to automatically trigger on dock plug/unplug. Unfortunately the unplug event will be too late as the device will already be unplugged, but the plug event may be handy... I used these udev events to automatically configure external monitors with xrandr.

--Tonko 08:20, 6 September 2011 (CEST)

Ok. It is me again. It is possible to unplug linux definietly. It is also possible probably to plug it back, but only if kernel was booted with laptop docked in. This is because Linux uses resource assigned as assigned by ACPI / BIOS. If you boot to Linux kernel without being docked, and then try to dock, you will basically have problems with BAR, and kernel will say there is no enough resources, like virtual memory, IO ports, DMA channels or interrupts lines.

As of unpluggin, you need to unmount filesystems, make sure other processes (like smart, hddtemp) doesn't use disks, rmmod modules of controler and cdrom/floppy drive, then power down a particular PCI bus, I do not remember how it is done. And can undock it. In fact it can be scripted, and added as even handler after pressing undock button (and give some success or error sound when it is done, to notify user).

As of pluging things back, you basically need to rescan PCI bus. This is done by echoing something to scan file somewhere under in /proc or /sys/bus/pci. I would need to check. Then modprobing modules. It will however will not work, becasue sure, devices will be detected, but kernel will have problems with some PCI cards, which uses DMA or IOport. However, if you booted with kernel in dock station it may work.

It may be possible to reassign resources, or make kernel aware that we may need to additional resources in the future, which are not present at boot time, and declare its size, to make use them on docking time. I was searching some linux kernel mailing lists, and there was some discussions on it, but nobody had similar problem.

--Baryluk 02:41, 23 March 2012 (CET)

Using trackpoint or touchpad makes fan in Dock spin up

This is really strange but real.

Every time I move a mouse cursor using trackpoint a fan inside Dock II spin up significantly to be quite loud. Spinning stops exactly in a moment I stop touching trackpoint. If I just shake a mouse cursor it start, when I shake it more, or move it around faster, fan also becomes louder. When I have trackpoint point constantly in one direction it is also spinning fast. It stops spinning (became really quite) only when trackpoint is at rest (I can have a finger on it).

I know this behavior of my dock for some time.

When I use keyboard, or press mouse buttons (when when pressing them constantly), no such issue arise.

I just discovered also that using touchpad makes same problem! Even touching it and not moving at all will make fan spin faster. After stopping using touchpad, it takes about 2-3 seconds to make fan quite again. Left button doesn't do anything when pressing or depressing. However pressing right button makes a fan lauder for a moment, then stops, and same happens when depressing (fan is louder for a moment, and then quite, like 2-3 seconds).

So why this is working this way? Is my dock or laptop failing? I'm not sure how it is related. It is not related to the video screen update, after moving cursors, as problem doesn't happen when using external USB mouse or when playing movies, or updating screen when typing on keyboard. It isn't also bigger current consumption, and this doesn't really happen when jumping from 800MHz to 1.7Ghz, at least I think so.

I'm using T43.

Maybe it is power consumption, maybe some cabling is bad?

Any ideas? Anybody with same problem?

Witek --Baryluk 02:42, 23 March 2012 (CET)

Audio quality

Hi, is this only me or audio output using jack port on Dock II make sound everything bad? I cannot tollerate it, and always plug back to laptops own ports. Not tested with mic, but listening to music on headphones connected to dock is of quite poor quality. I'm using T43. Does anybody else have same problem? --Baryluk 02:48, 23 March 2012 (CET)

Power Consumption

Hello, anyone know how much power TPD-II consumes? Is it worth to switch from Mini-Dock (with external 120W power supply) to ThinkPad Dock II due to power-saving reasons?