Installing openSUSE 10.3 Beta 1 on a ThinkPad T61

From ThinkWiki
Jump to: navigation, search

Opening Notes:

OpenSUSE 10.3 Beta 1 is (shock) beta software, and not stable enough for production use. Although I must add that the distro is looking very promising, I had very little problems getting things to work.

Hard Disk Controller

AHCI sata works out of the box, no need for tweeks as far as I can see.



8.23.2007 intel 965 works with i915 resolution package, including compiz. minor modification of xorg.conf is required.

add the following to xorg.conf

 Section "Monitor"
	Identifier  "TVOutput"
	Option 	    "Disable" "true"

and modify your device section to include

Option “monitor-TV” “TVOutput”


After the install was finished I found myself without X or terminal access. I just rebooted into the safe-mode and started sax2. to get a temporary X config (only 800x600 worked with the vesa driver)

Download the Nvidia Driver from, at time of writing 100.14.11. Install gcc, kernel headers, kernel source through yast.

Then, as root from a virtual terminal:

Template:Rcxdm stop

Template:Sh -q

Template:Sax2 -m 0=nvidia

If the file you download is newer that 100.14.11 make sure you modify the command appropriately

Reboot: Template:Shutdown -r now

After Rebooting KDE/Gnome should start normally

With each new Kernel release, the "sh -q" command must be repeated


Integrated 10/100/1000 Intel Supported out of the box, no changes/tweaks necessary


IWL 4965 works great with the iwlwifi and iwl4965 packages installed. Add the non-oss repository.

FireWire / USB2.0:

Not tested


I have not tested this yet, must first install codec support. The speakers are reproducing sound spoken to the internal microphone.


s2ram works with minor modification, as root:

{{touch /etc/pm/config.d/sleep; echo "S2RAM_OPTS=\"-f\"" >> /etc/pm/config.d/sleep}}

Little or no investigation thus far; but some of the acpi modules are not loaded at boot, so the computer does not monitor the battery.