Installation instructions for the ThinkPad X61s

From ThinkWiki
Jump to: navigation, search

Ubuntu 7.10

The following features work out-of-the-box with Ubuntu 7.10:

  • 3D rendering
  • Hot keys: sound, brightness, keyboard light, monitor, suspend
  • LAN
  • WLAN
  • ACPI, battery monitor
  • Sound card
  • Bluetooth

The following features don't work out-of-the-box:

  • suspend fails: seemingly due to the ipw3945 ethernet driver
  • Trackpoint's mouse wheel emulation

Still not solved?

  • Bluetooth: Under Gnome I can not enable and disable bluetooth from linux. Have to run the windows program which controls bluetooth and enable it. After reboot it will remain enabled (the led indicates it). However there is a hardware switch which turns off all radio communications (including Bluetooth, Wireless Lan, and WAN (3G)), and there is also the possibility to disable each one of them separately from BIOS.

Bluetooth can be enabled by $echo enable > /proc/acpi/ibm/bluetoothBolle 20:58, 28 December 2007 (CET)

  • 3G: Not tested.
  • Fingerprint reader: Not tried to install it. Suggestions about installation and use?

For more information see Installation instructions for the ThinkPad X61.

Kubuntu 7.10 (Gutsy Gibbon)

Used Kernel: 2.6.22-14-generic

There are some subtle differences to the Ubuntu installation mentioned above, so I make a separate section. I also made a non-standard installation by using LVM over dm-crypt to get an entirely encrypted disk, except the /boot partition.

The following features work out of the box:

  • LAN
  • WLAN
  • Power Management
  • Sound (without hotkey support!)
  • Bluetooth

The following features did not work:

  • hibernate

Entering and waking up from hibernation took a bit too long, giving me a bunch of too-fast-to-read USB errors on the console screen before shutting down. Notebook also stays blank screen mode after wakeup, until pressing the "enter" key to provoke a wrong password entry in the screensaver dialogue.

  • suspend to RAM

Waking up from suspend to RAM does not work, the backlight of the screen is not reactivated. Need to reboot to reactivate.

  • hotkeys

The hotkeys for adjusting the brightness, mute, volume up/down and ThinkVantage do not work. Using "acpi_listen" shows, that some of the keys are recognized, so Kubuntu does not interpret them correctly. Some keys are not recognized at all. Here is an overview:

Key pressed result
FnPos1 (brightness up) ibm/hotkey HKEY 00000080 00001010, video LCD0 00000086 00000000
FnEnde (brightness down) ibm/hotkey HKEY 00000080 00001011, video LCD0 00000087 00000000
Mute first time: METHOD UCMS 00000000 00000000, after that: nothing
Volume down first time: METHOD UCMS 00000000 00000000, after that: nothing
Volume up first time: METHOD UCMS 00000000 00000000, after that: nothing

However, adjusting brightness with KDE Powermanager does work, as well as adjusting volume using Kmix. You can also "echo" values into /proc/acpi/ibm/...


I have not tested it yet, I am still looking for a good UMTS flatrate. The device does show properly identified during bootup (use dmseg if you did not pay attention :) and should be usable via kppp.

ubuntu 8.04 (Hardy Heron)

Used Kernel: 2.6.24-19-generic

The following features work out of the box:

  • LAN
  • WLAN (small bug)
  • Power Management
  • Sound (with volume hotkey support!)
  • Bluetooth
  • hibernate
  • suspend to RAM
  • hotkeys

I don't have the umts option and therefore cannot test it

Bugs :

  • The wifi button on the keyboard (Fn-F5) enables bluetooth
  • To enable/disable the wifi, you must use the nm-applet which works properly but doesn't light up the thinkpad led.

Features not working at the install

  • fingerprint reader

In order to enable it, just follow this page of the wiki

Debian Testing (Lenny)

with kernel 2.6.22-2

There are some observations on:

I would remark that I do control brightness of the screen from command line (not with the keys):

aptitude install xbacklight; xbacklight --help

I have also installed Compiz: and don't forget to configure compiz as explains B.Goglin:

There is a problem with reproducing video while using Compiz:

It is recommended the insertion of the module:

modprobe thinkpad_acpi

Debian Stable (Etch)

I have followed the following steps to do the installation:

1) Install Edgy Etch in its normal way.

Several things did not work: acpi, sound, clock restoration, wireless, graphics driver set to vesa.

The ethernet card works perfectly and the vesa driver works fine.

2) Download a new kernel (in my case

3) Compile and install the kernel the "Debian way" (

I had to enable several deprecated ACPI items because Debian Stable access some resources the old way.

I had also to enable some parameters concerning iwlwifi 4965 (wireless card). It is hidden because you have to activate:

Networking → Wireless → [M]Improved wireless configuration API

before selecting:

Device Drivers → Network Device Support → Wireless LAN → [M]Intel Wireless WiFi Link Drivers


Device Drivers → Network Device Support → Wireless LAN → [M]Intel Wireless WiFi 4965AGN

4) Include backports sources into /etc/apt/sources.list.

deb etch-backports main contrib non-free

5) Install package sysvinit from backports.

# apt-get -t etch-backports install sysvinit

Necessary because the new kernel has reimplemented the access to SATA disks, and Edgy Etch default shutdown does not park the disk heads correctly. (A message about SPIN DOWN the disk was shown).

6) Edit /etc/default/rcS and set HWCLOCKPARS="--directisa".

7) Download the file iwlwifi-4965-ucode- from, decompress it and copy iwlwifi-4965-1.ucode to /lib/firmware.

8) Edit /etc/network/interfaces and add the following lines:

allow-hotplug wlan0

iface wlan0 inet dhcp

Next, you can configure your wireless connection throw iwconfig or any other configuration tool.

So, finally:

  • Sound works: Since each time I wake up the computer the volume is reseting.

(After deinstalling libesd, installing libesd-alsa0 and playing a bit with alsamixer the problem went out.

  • Ethernet works.
  • Wireless works.
  • ACPI works partially: temperature, fan and battery indications works perfectly throw acpitool and icon indication respectively.
  • ThinkLight works, but the other Fn buttons does not: brightness, battery, sleep, etc.
  • Suspend and Hibernation does not work. Hibernation seems to work, but after saving the session and poweroff, the system wake up automaticallly.
  • Clock restauraton works.
  • I still work with driver vesa. It works fine, and makes what I want when I hire an extenal monitor (poweroff the laptop monitor and use the external one), but I have some problems when I logout from X and go to text terminal (ALTF1) without external monitor. The screen turns blank.
  • I don't know if TurboMemory is recognized. I would like to configure it as swap partition.

I will try to solve this problems in near future.

NOTE: Intel driver for X3100 (xf86-video-intel, cannot compile with xorg < 1.3, and Edgy Etch includes 1.1 version. So, it seems that the only way to use the driver is to upgrade xorg: you have to compile a new version because I did not see candidate files at

Other Linux (meta)distros