From ThinkWiki
Jump to: navigation, search

This is a Analog Devices High-Definition Audio 1.0 codec


  • Chipset: AD1981HD
  • Interface: HD Audio 1.0
By default, the volume buttons on the laptop control the volume of the hardware while software mixers like alsamixer and aumix increase or decrease the volume relative to the hardware volume.

Linux ALSA driver

HD Audio is supported by the snd-hda-intel kernel module

Installation on Debian GNU/Linux

The AD1981HD installs by default in Debian. To get it to work type 'alsaconf' on the command line as the root user.

# alsaconf

To become root, type su at the command line.


As of ALSA 1.0.13 the master volume has returned. Download the latest modules from your distrobution to fix this problem. Otherwise as a temporary fix add model=hp to the snd-hda-intel module option. This will return the master volume control to your control.
If you use Debian, edit /etc/modprobe.d/sound to change ALSA module options.
  • If you experience crackling noises, this can be avoided by adding the position_fix=2 optional argument for the module.
  • If you have problems recording audio, try selecting "Front Mic" as the capture device.
There have been reported problems using arecord while debugging, it's recommended to instead use Audacity.
  • According to a bug in the BIOS, the modem disables the audio device too. If you are having problems with your soundcard and have disabled your modem, try re-enabling it. On some systems disabling the modem results in fixing some problems, so if you haven't disabled the modem, try it. On the T60p model, the in-kernel ALSA system will report "azx_get_response timeout"; re-enabling the modem fixed this issue and brought audio back. This also works for the X60s.
  • Another bug seems to also exist when the Wireless LAN (sierra wireless card) is disabled in the BIOS. Re-enabling the Wireless LAN will enable sound.
  • external / internal microphone does not work for me. see

(different laptops but same sound chip)

This problem was fixed for me by specifying the model option to 'ref' for the snd-hda-intel module (see first problem).
'laptop' as model option is also working but 'thinkpad' should be the preferred model option.

ThinkPads this chip may be found in