Talk:Script for enabling the fingerprint reader with BioAPI

From ThinkWiki
Revision as of 02:55, 30 April 2006 by Thinker (Talk | contribs) (FC5 merged)

Jump to: navigation, search

With only 2 minor changes this script works on fc5 as well...

You need to change the line that says:

grep -q 'Fedora Core release 4' /etc/redhat-release || { echo \

to say:

grep -q 'Fedora Core release 5' /etc/redhat-release || { echo \


Also, you need to add a patch for the bioapi to get it to compile on fc5 with gcc4.1:

---cut-- diff -Nur bioapi-1.2.2.orig/addins/dl/mds/dal_classes.h bioapi-1.2.2/addins/dl/mds/dal_classes.h --- bioapi-1.2.2.orig/addins/dl/mds/dal_classes.h 2005-06-09 18:35:44.000000000 -0600 +++ bioapi-1.2.2/addins/dl/mds/dal_classes.h 2006-03-28 17:21:49.000000000 -0700 @@ -455,7 +455,7 @@

               DAL_DATABASE_INFO_REF_PTR &prefDatabase,
        PORT_MUTEX_HANDLE &Mutex);

- CSSM_RETURN DAL_DATABASE_INFO_LIST::GetDBNamesAndParameters( + CSSM_RETURN GetDBNamesAndParameters(

                               CSSM_DL_DB_HANDLE DLDBHandle,
                               DAL_DB_OPEN_PARAM_PTR pParam);
};

--cut--

I added a line to apply this patch:

... tar xjf bioapi-latest.tar.bz2 pushd bioapi-1.2.2 patch -p1 < ../bioapi-gcc41.patch ./configure --with-Qt-dir=no --prefix=$WHERE ...

Can anyone else confirm that works and perhaps merge into the main script?


Merged.

--Thinker 02:55, 30 April 2006 (CEST)