Talk:Problems with fglrx

From ThinkWiki
Revision as of 18:57, 14 January 2006 by Gsmenden (Talk | contribs) (8.20.8 does work fine with current Debian sid packages)

Jump to: navigation, search

using kernel AGP vs fglrx AGP

Anyone know whether this makes a performance and/or stability difference?

8.20.8 does work fine with current Debian sid packages

spiney@t43p:~$ dpkg -l xserver-xorg
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name                         Version                      Description
+++-============================-============================-==================
ii  xserver-xorg                 6.9.0.dfsg.1-2               the X.Org X server
spiney@t43p:~$ fglrxinfo 
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: MOBILITY FireGL V3200 Pentium 4 (SSE2) (FireGL) (GNU_ICD)
OpenGL version string: 1.3.5519 (X4.3.0-8.20.8)

--spiney


Ahh - thanks for the info. You perhaps compiled the modules for the drivers yourself and did not use the debian packaged fglrx-driver? Thus, it must be an unneeded limitation on the debian packaged driver which limits its installation... Full listing at http://packages.debian.org/unstable/x11/fglrx-driver which lists as required packages:

xserver-xorg (<< 6.8.99)
 the X.Org X server 
xserver-xorg (>= 6.8.0) 

The first limitation (<<6.8.99) is what prevents installation. I'm sure I could force apt to install it, but I may go back to compiling the modules myself, as using fglrx 8.20.8 with kernel 2.6.15 needs a small patch to compile correctly anyway... --gsmenden

Spiney, where exactly do you have your package from? I re-build the 8.20.8-package from debian with the <<6.8.99 dependecy removed, but when I try to run X, I get

[R200Setup] X version mismatch - detected X.org 7.0.0.0, required X.org 6.8.0.0
(EE) Failed to load module "fglrx" (module requirement mismatch, 0)

Any hints? --[User:nomeata|nomeata]

I used the ati-installer (the huge download), created a Debian sid package and installed it, but got the same error. The installer seems to fetch the wrong driver version from the archive, so I extracted it with

./ati-driver-installer-8.20.8-i386.run --extract <sometempdir>

and put the necessary files from the created <sometempdir>/x690 subdirectory into /usr by hand. All IIRC, it's been some time since. :)

--spiney 07:29, 11 Jan 2006 (CET)

Thanks for the pointer. This is how you get proper debian packages out of the ati-installer:

./ati-driver-installer-8.20.8-i386.run --extract fglrx-tmp
cd fglrx-tmp
$editor packages/Debian/ati-packager.sh #  in the line "sid|unstable) X_DIR=x680;;", put a x690 for the x680
./fglrx-tmp/packages/Debian/ati-packager.sh --buildpkg sid
cd ..
sudo dpkg -i fglrx-kernel-src_8.20.8-1_i386.deb fglrx-driver_8.20.8-1_i386.deb

--Nomeata 00:35, 13 Jan 2006 (CET)



Nice - confirmed works on my T43p running sid. From then on (or until 8.21.x comes out) you'll have to tell apt to hold back fglrx-driver package, or it will try to "update" fglrx-driver to 8.20.8-1.1 and therefore revert back to the problematic drivers. --gsmenden


Thanks for the info, Nomeata, that's a lot cleaner a solution than my manual way.

--spiney 08:32, 13 Jan 2006 (CET)


So has anybody gotten this working under 2.6.15 with x.org 6.9? Alas, the patch that you need is not able to be applied if you use the fglrx-installer, and manual compilation will not let me use the files with x.org 6.9. Looks like we'll have to wait until the next release for both. --gsmenden 12:39, 14 Jan 2006 (EST)

Disabling the external VGA port?

Does anyone know how disable the VGA port completely even when a cable is attached? Fiddling around with the DesktopSetup and ForceMonitor options didn't do the trick for me, and the MonitorLayout option found in some documentation is no longer valid in the current fglrx driver.

--spiney 19:42, 10 Jan 2006 (CET)