Difference between revisions of "Installing Ubuntu 9.10 (Karmic Koala) on a ThinkPad X200"

From ThinkWiki
Jump to: navigation, search
m
(Trackpoint)
 
(34 intermediate revisions by 14 users not shown)
Line 1: Line 1:
 
[[Category: X200]]
 
[[Category: X200]]
Just brief info for now as I haven't time to test all features yet. Please update if you have info on features marked as untested.
+
Just brief info for now as I didn't have time to test all features yet. Please update if you have info on features marked as untested.
 +
 
 +
These notes also apply to the x200 tablet.
  
 
==Installation==
 
==Installation==
  
* Installing from desktop cd:<br>not tested
+
* Installing from desktop cd:<br>Works fine with external usb drive
 +
 
 +
* Installing from USB stick:<br> Works fine
  
 
* Installing from alternate cd:<br>works fine with optical drive in [[X200 UltraBase]], just follow the steps
 
* Installing from alternate cd:<br>works fine with optical drive in [[X200 UltraBase]], just follow the steps
  
* Installing via wubi:<br>not tested
+
* Installing via wubi:<br>works fine, except hibernate (normal for wubi installations)
 +
 
 +
* Updating from Jaunty:<br>not tested
  
 
==Features support==
 
==Features support==
Line 14: Line 20:
 
===Display===
 
===Display===
 
* internal LCD: works fine
 
* internal LCD: works fine
* external VGA: not tested
+
* external VGA: works fine
 
* external VGA via ultraBase: works fine
 
* external VGA via ultraBase: works fine
 
* DisplayPort via ultraBase: works fine
 
* DisplayPort via ultraBase: works fine
  
 
===Trackpoint===
 
===Trackpoint===
works fine
+
The middle Scrollbutton won't work out-of-the-box, you can solve it with the help of the following Link: http://samiux.wordpress.com/2008/11/02/howto-lenovo-thinkpad-scroll-button-on-ubuntu-810/ <br>
 +
I find the middle scrollbutton doesn't works very well for me by following these steps.<br>
 +
The solution I currently use is to automatically execute the following commands:<br>
 +
Quote:
 +
xinput set-int-prop "TPPS/2 IBM TrackPoint" "Evdev Wheel Emulation" 8 1
 +
xinput set-int-prop "TPPS/2 IBM TrackPoint" "Evdev Wheel Emulation Button" 8 2
 +
xinput set-int-prop "TPPS/2 IBM TrackPoint" "Evdev Wheel Emulation Y Axis" 8 4 5
 +
xinput set-int-prop "TPPS/2 IBM TrackPoint" "Evdev Wheel Emugreatlation X Axis" 8 6 7
 +
 
 +
Another way to enable scrolling even if the instructions are a little older: http://www.thinkwiki.org/wiki/How_to_configure_the_TrackPoint#Scrolling. You can also try using gpointing-device-settings instructions as described at the top of the page but it's not persistent when you go into suspend-resume.
 +
 
 +
If you want to use the middle Scrollbutton, you will also likely want to disable middle-button paste.  To do so just add the following line to the above:
 +
xinput set-button-map "TPPS/2 IBM TrackPoint" 1 0 3
  
 
===WiFi===
 
===WiFi===
*Intel 5100: not tested
+
*Intel 5100: works fine
*Intel 5300: not tested
+
After updating the kernel to 2.6.31-15-generic, the old kernel panic problem which used to happen in ubuntu 8.04 or older release, comes up again. I don't know whether this affects a fresh installation of karmic as I update the system immediately after I get a wired connection.<br>
*Intel 5350: works fine, kernel sees it as 5300 so the above probably also works
+
I have the linux-backports-modules-wireless-karmic-generic package installed. Now it works fine.
 +
*Intel 5300: works fine
 +
*Intel 5350: works fine, kernel sees it as 5300
  
 
===Bluetooth===
 
===Bluetooth===
Line 30: Line 50:
  
 
===3G===
 
===3G===
not tested
+
Works fine
  
===webcam===
+
===GPS===
not tested
+
Works, with the installation of http://sourceforge.net/apps/mediawiki/mbm/index.php?title=Main_Page#GPS_Control_.28mbm-gpsd.29
 +
 
 +
Note: mbm-gpsd is not running after wake from suspend
 +
 
 +
===Webcam===
 +
Works perfectly.
  
 
===Sound===
 
===Sound===
* internal speakers: not tested
+
* internal speakers: works fine, good volume
* headphones: not tested
+
* headphones: works
 
* headphones via ultrabase: works fine
 
* headphones via ultrabase: works fine
* internal mic: works fine
+
* internal mic: works fine, good sensitivity
 
* mic via ultrabase: not tested
 
* mic via ultrabase: not tested
 +
* Volume up and down keys Work fine, Mute does not.
 +
(Mute actually works but you won't find an OSD showing you it's on mute, unlike volume up and down.  Additionally, plugging in your headphones even while on mute will let you hear sounds)
 +
 +
'''To get OSD working with Mute:''' (http://www.codefx.biz/2009/11/x200-mute-button)
 +
 +
Edit the file {{path|/etc/grub.d/10_linux}} and add {{bootparm|acpi_osi|Linux}} to the line with $GRUB_CMDLINE_LINUX_DEFAULT, so it will look like this:
 +
 +
"${GRUB_CMDLINE_LINUX} ${GRUB_CMDLINE_EXTRA} ${GRUB_CMDLINE_LINUX_DEFAULT} acpi_osi=Linux" \
 +
 +
Then run '''{{cmduser|sudo update-grub}}'''
 +
 +
{{NOTE|Up to kernel 2.6.32 this seems to be the only way to fix the mute problem. However, this fix introduces new issues. Therefore, another, clean solution is being implemented as soon as kernel 2.6.33.}}
  
 
===Sensors===
 
===Sensors===
mostly work, [[Tp smapi]] adds more readable sensor names, for HDD hddtemp is needed
+
mostly work, for HDD hddtemp is needed
 +
 
 +
===Fingerprint===
 +
Doesn't work, see http://www.reactivated.net/fprint/wiki/Unsupported_devices#AuthenTec_AES2550_.26_AES2810
  
 
===HDAPS===
 
===HDAPS===
works with [[Tp smapi]]. After installing hdapsd edit /etc/default/hdapsd make sure START is set to "yes", DISK to "sda" and adjust SENSITIVITY (50 works ok for most people).
+
I couldn't make hdaps module to use [[Tp smapi]]. It seems module-assistant does not build patched version of hdaps module from tp-smapi-source package.<br>
 +
Nevertheless hdaps seems to work fine with thinkpad_ec. After installing hdapsd edit /etc/default/hdapsd make sure START is set to "yes", DISK to "sda" and adjust SENSITIVITY (50 works ok for most people).
 +
 
 +
edit: use tp-smapi as in [http://elf.org/x200-tablet-accelerometer]
 +
 
 +
===Fan===
 +
While the X200 is known for it's good cooling system, when running Ubuntu the fan seems to run constantly at around 3000rpm after it reached a certain threshold temperature. See the related bugreport on Launchpad:
 +
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/380303
 +
 
 +
For reasons of power consumption and noise reduction you might want to control the fans on your own using tp-fan, see [[ACPI_fan_control_script#ThinkPad_Fan_Control_GTK_GUI_tool]]. The Jaunty PPA seems to work fine on Karmic.
 +
 
 +
For me the following settings seem to work:
 +
Check both boxes, set all sensors to 15% and the temperature threshold of all sensors to 25°C/68°F. With this settings the fan runs constantly with 2000rpm.
  
 
===Suspending===
 
===Suspending===
 
Works fine as long as you don't suspend when docked.
 
Works fine as long as you don't suspend when docked.
 +
 +
edit: Suspend with dock works for me.
  
 
===Hibernating===
 
===Hibernating===
Not tested
+
Works fine when hibernating when undocked. Not tested when docked.
  
 
===Docking and Undocking===
 
===Docking and Undocking===
* Docking works ok, system even tries to switch automatically to saved external monitor display configuration and sometimes it even does the smart thing
+
* Docking works ok. System even tries to switch automatically to saved external monitor display configuration and sometimes it even does the smart thing
 
* Before undocking you must always press "pre-undock" button on the left side of docking station and wait until green arrow allows you to proceed. Otherwise system will start to beep at you and it will probably get confused.
 
* Before undocking you must always press "pre-undock" button on the left side of docking station and wait until green arrow allows you to proceed. Otherwise system will start to beep at you and it will probably get confused.
 
* Undocking and/or pressing "pre-undock" button switches automatically display to internal LCD only so you don't have to worry about it.
 
* Undocking and/or pressing "pre-undock" button switches automatically display to internal LCD only so you don't have to worry about it.
* automatic umounting of devices connected to docking station was not tested yet.
+
* Undocking doesn't umount automatically devices connected to docking station (usb pendrives, optical drive) so you must remember to do this manually. See https://bugs.launchpad.net/ubuntu/+source/pm-utils/+bug/433682
* suspending or hibernating when docked is not a good idea as system will get confused when resumed not docked also.
+
* Suspending or hibernating when docked is not a good idea as system will probably get confused when resumed not docked also.
 +
 
 +
===MemoryCardReader===
 +
Works
 +
 
 +
 
 +
==Tablet==
 +
 
 +
===Screen===
 +
* Screen rotation can be enabled with xrandr and https://launchpad.net/~thjaeger/+archive/tabletpc/+packages<br>
 +
* TouchScreen requires recalibration as described https://help.ubuntu.com/community/X61T <br>
 +
* Pen pressure sensitivity works
 +
[[Category:Ubuntu_9.10]]
 +
 
 +
== Automatic Brightness Controll==
 +
Possible using a script like the one at this link:<br>
 +
http://gnome-look.org/content/show.php?content=128780&vote=good&tan=54635248<br>
 +
Remember to install php5-cli and php5-gd, in the cfg file: pbr=1 (or lower if preferred a brighter screen)<br>
 +
There is an error in the script.... some [] have to be added at the if statement (line 108 and the others) <br>
 +
The scrpt has to be run with sudo privileges, the password in the cfg file doesn't work (8-2010).

Latest revision as of 17:10, 10 September 2010

Just brief info for now as I didn't have time to test all features yet. Please update if you have info on features marked as untested.

These notes also apply to the x200 tablet.

Installation

  • Installing from desktop cd:
    Works fine with external usb drive
  • Installing from USB stick:
    Works fine
  • Installing from alternate cd:
    works fine with optical drive in X200 UltraBase, just follow the steps
  • Installing via wubi:
    works fine, except hibernate (normal for wubi installations)
  • Updating from Jaunty:
    not tested

Features support

Display

  • internal LCD: works fine
  • external VGA: works fine
  • external VGA via ultraBase: works fine
  • DisplayPort via ultraBase: works fine

Trackpoint

The middle Scrollbutton won't work out-of-the-box, you can solve it with the help of the following Link: http://samiux.wordpress.com/2008/11/02/howto-lenovo-thinkpad-scroll-button-on-ubuntu-810/
I find the middle scrollbutton doesn't works very well for me by following these steps.
The solution I currently use is to automatically execute the following commands:
Quote:

xinput set-int-prop "TPPS/2 IBM TrackPoint" "Evdev Wheel Emulation" 8 1
xinput set-int-prop "TPPS/2 IBM TrackPoint" "Evdev Wheel Emulation Button" 8 2
xinput set-int-prop "TPPS/2 IBM TrackPoint" "Evdev Wheel Emulation Y Axis" 8 4 5
xinput set-int-prop "TPPS/2 IBM TrackPoint" "Evdev Wheel Emugreatlation X Axis" 8 6 7

Another way to enable scrolling even if the instructions are a little older: http://www.thinkwiki.org/wiki/How_to_configure_the_TrackPoint#Scrolling. You can also try using gpointing-device-settings instructions as described at the top of the page but it's not persistent when you go into suspend-resume.

If you want to use the middle Scrollbutton, you will also likely want to disable middle-button paste. To do so just add the following line to the above:

xinput set-button-map "TPPS/2 IBM TrackPoint" 1 0 3

WiFi

  • Intel 5100: works fine

After updating the kernel to 2.6.31-15-generic, the old kernel panic problem which used to happen in ubuntu 8.04 or older release, comes up again. I don't know whether this affects a fresh installation of karmic as I update the system immediately after I get a wired connection.
I have the linux-backports-modules-wireless-karmic-generic package installed. Now it works fine.

  • Intel 5300: works fine
  • Intel 5350: works fine, kernel sees it as 5300

Bluetooth

generally works, but see https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/381913

3G

Works fine

GPS

Works, with the installation of http://sourceforge.net/apps/mediawiki/mbm/index.php?title=Main_Page#GPS_Control_.28mbm-gpsd.29

Note: mbm-gpsd is not running after wake from suspend

Webcam

Works perfectly.

Sound

  • internal speakers: works fine, good volume
  • headphones: works
  • headphones via ultrabase: works fine
  • internal mic: works fine, good sensitivity
  • mic via ultrabase: not tested
  • Volume up and down keys Work fine, Mute does not.

(Mute actually works but you won't find an OSD showing you it's on mute, unlike volume up and down. Additionally, plugging in your headphones even while on mute will let you hear sounds)

To get OSD working with Mute: (http://www.codefx.biz/2009/11/x200-mute-button)

Edit the file /etc/grub.d/10_linux and add acpi_osi=Linux to the line with $GRUB_CMDLINE_LINUX_DEFAULT, so it will look like this:

"${GRUB_CMDLINE_LINUX} ${GRUB_CMDLINE_EXTRA} ${GRUB_CMDLINE_LINUX_DEFAULT} acpi_osi=Linux" \

Then run $ sudo update-grub

NOTE!
Up to kernel 2.6.32 this seems to be the only way to fix the mute problem. However, this fix introduces new issues. Therefore, another, clean solution is being implemented as soon as kernel 2.6.33.

Sensors

mostly work, for HDD hddtemp is needed

Fingerprint

Doesn't work, see http://www.reactivated.net/fprint/wiki/Unsupported_devices#AuthenTec_AES2550_.26_AES2810

HDAPS

I couldn't make hdaps module to use Tp smapi. It seems module-assistant does not build patched version of hdaps module from tp-smapi-source package.
Nevertheless hdaps seems to work fine with thinkpad_ec. After installing hdapsd edit /etc/default/hdapsd make sure START is set to "yes", DISK to "sda" and adjust SENSITIVITY (50 works ok for most people).

edit: use tp-smapi as in [1]

Fan

While the X200 is known for it's good cooling system, when running Ubuntu the fan seems to run constantly at around 3000rpm after it reached a certain threshold temperature. See the related bugreport on Launchpad: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/380303

For reasons of power consumption and noise reduction you might want to control the fans on your own using tp-fan, see ACPI_fan_control_script#ThinkPad_Fan_Control_GTK_GUI_tool. The Jaunty PPA seems to work fine on Karmic.

For me the following settings seem to work: Check both boxes, set all sensors to 15% and the temperature threshold of all sensors to 25°C/68°F. With this settings the fan runs constantly with 2000rpm.

Suspending

Works fine as long as you don't suspend when docked.

edit: Suspend with dock works for me.

Hibernating

Works fine when hibernating when undocked. Not tested when docked.

Docking and Undocking

  • Docking works ok. System even tries to switch automatically to saved external monitor display configuration and sometimes it even does the smart thing
  • Before undocking you must always press "pre-undock" button on the left side of docking station and wait until green arrow allows you to proceed. Otherwise system will start to beep at you and it will probably get confused.
  • Undocking and/or pressing "pre-undock" button switches automatically display to internal LCD only so you don't have to worry about it.
  • Undocking doesn't umount automatically devices connected to docking station (usb pendrives, optical drive) so you must remember to do this manually. See https://bugs.launchpad.net/ubuntu/+source/pm-utils/+bug/433682
  • Suspending or hibernating when docked is not a good idea as system will probably get confused when resumed not docked also.

MemoryCardReader

Works


Tablet

Screen

Automatic Brightness Controll

Possible using a script like the one at this link:
http://gnome-look.org/content/show.php?content=128780&vote=good&tan=54635248
Remember to install php5-cli and php5-gd, in the cfg file: pbr=1 (or lower if preferred a brighter screen)
There is an error in the script.... some [] have to be added at the if statement (line 108 and the others)
The scrpt has to be run with sudo privileges, the password in the cfg file doesn't work (8-2010).