Installing Ubuntu 8.04 (Hardy Heron) and Ubuntu 8.10 (Intrepid Ibex) on a ThinkPad X200

From ThinkWiki
Revision as of 14:12, 3 October 2008 by Ashaw (Talk | contribs) (←Created page with ''''Apologies in advance:''' The original author of this entry hopes that others will improve on this preliminary effort. ==Install== Started off working w. Ubuntu 8.04 i...')

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Apologies in advance: The original author of this entry hopes that others will improve on this preliminary effort.

Install

Started off working w. Ubuntu 8.04 install using the optical drive in the X200 ultrabase. Everything went swimmingly - ethernet worked out of the box as did the optical drive itself.

Wound up upgrading to the 8.10 beta b/c of wireless troubles. See below.

Ultrabay

Handles install without any problem - note: while the machine is in the bay, it forces you to use the ethernet port on the bay.


Ethernet

Intel GigE worked out of the box w. 8.04.

8.10 beta not supporting Intel GigE hardware yet, however (see this technical overview for more details), so unless you wanna try some serious hacking I wouldn't try to do a net install of 8.10 using the ethernet until the final release.


Wireless

Ah, the wireless.

run <lshw -C network> and sort out which wireless hardware you're working with.

For Atheros, check out this forum post

For Intel 5100 and 5300 on 8.04, neither the recommended drivers (iwl5000) nor ndiswrapper did the trick. It's possible that manually-upgrading the kernel to 2.27 would do it.

On the other hand, with 8.10 the Intel 5300 works out of the box. Running <lshw -C network> again shows that it's the iwlagn driver (pre-loaded with the 2.27 kernel) that does the trick.

Fan

As reported elsewhere, the fan seems to run constantly while the machine is on under 8.04 and 8.10. Will report back if/when I find a fix in the next few days.

Power Mgmt

Not sure what's going on here yet, but the battery claims to have only ~3 hours of life after a full charge.


Suspend

Suspending through the Gnome desktop does not work.

Sound

Works out of the box under 8.04 and 8.10

Camera

Untested.

VGA

"Unclaimed"