Difference between revisions of "ATI Mobility Radeon X1400"

From ThinkWiki
Jump to: navigation, search
m (External VGA port)
(Proprietary ATI driver on Ubuntu Feisty)
 
(21 intermediate revisions by 11 users not shown)
Line 3: Line 3:
 
|style="vertical-align:top" |
 
|style="vertical-align:top" |
 
<div style="margin: 0; margin-right:10px; border: 1px solid #dfdfdf; padding: 0em 1em 1em 1em; background-color:#F8F8FF; align:right;">
 
<div style="margin: 0; margin-right:10px; border: 1px solid #dfdfdf; padding: 0em 1em 1em 1em; background-color:#F8F8FF; align:right;">
=== ATI Mobility Radeon X1400 ===
 
This is an ATI video adapter.
 
  
=== Features ===
+
This is an ATI video adapter.
 +
== Features ==
 
* Chipset: ATI M54
 
* Chipset: ATI M54
 
* PCI ID: 1002:7145
 
* PCI ID: 1002:7145
 
* PCI Express x16
 
* PCI Express x16
 
* 128MB GDDR1 video memory
 
* 128MB GDDR1 video memory
* Up to 512Mb HyperMemory - ATI's name for their GPUs that utilise shared and dedicated memory.
+
* Up to 512Mb [[HyperMemory]]
 
</div>
 
</div>
 
|style="vertical-align:top" |
 
|style="vertical-align:top" |
 
|}
 
|}
  
=== Linux X.Org driver ===
+
== Linux X.Org driver ==
Not Supported
+
Supported.
  
==== ThinkPad LCD ====
+
There is the [[radeonhd]] which is developed based on the published specs by AMD/ATI. It appears that most of this work is being merged into the [[radeon]] (aka, [http://www.x.org/wiki/radeon ati]) driver. On my system, the [[radeon]] driver has better 3D performance and is more stable than the [[radeonhd]] driver.
 +
 
 +
There is also the deprecated experimental [http://gitweb.freedesktop.org/?p=avivo/xf86-video-avivo.git;a=summary avivo driver] which works, but does not yet support any 3D acceleration.
 +
 
 +
== ThinkPad LCD ==
 
Display on the internal LCD works as long as you set the monitor settings correct.
 
Display on the internal LCD works as long as you set the monitor settings correct.
  
==== External VGA port ====
+
=== External VGA port ===
Works, but only if the X-server detects something plugged in here, eg. before X started or after a restart.
+
({{Z61m}}): Works, but only if the X-server detects something plugged in here, eg. before X started or after a restart.
  
==== SVideo port ====
+
({{T60}}): use '''aticonfig --enable-monitor=lvds,crt1''' to clone onto the VGA port. I use this to drive projectors all the time. Note that only the physical resolutions of the VGA port and the LVDS can differ (that means that if you use clone mode, you can have a 1400x1050 internal screen and 1680x1050 external and use both of them at the same time, but the internal screen will show only a portion of the real "desktop"; this area shifts when you move your mouse towards the edge of the viewport).
 +
 
 +
=== SVideo port ===
 
??
 
??
  
==== DVI port ====
+
=== DVI port ===
 
??
 
??
  
=== Proprietary ATI driver ===
+
== Linux X.org vesa driver ==
 +
 
 +
The vesa driver works out of the box.  If you can't make it to show higher resolutions, you may try to use lower color depth -- the best fonts sizes on 15.4 widescreen were achieved with 1400x1050 at 16 depth (highcolor).
 +
 
 +
== Proprietary ATI driver ==
 
Proprietary [[fglrx]] driver version 8.24.8 adds support for the x1400 chipset (according to ATI changelog). It works, including dualhead, 3d and video (XV) acceleration, when using the fglrx kernel module. (Without it, you get screen corruption including underlined mouse pointers.)
 
Proprietary [[fglrx]] driver version 8.24.8 adds support for the x1400 chipset (according to ATI changelog). It works, including dualhead, 3d and video (XV) acceleration, when using the fglrx kernel module. (Without it, you get screen corruption including underlined mouse pointers.)
  
Line 51: Line 60:
 
         BusID      "PCI:1:0:0"
 
         BusID      "PCI:1:0:0"
 
  EndSection
 
  EndSection
 
The kernel module doesn't work out of the box with the 2.6.16 kernel, you get undefined symbols such as module_get_request when inserting the module. The following patch to firegl_public.c fixes it (from  http://www.stanchina.net/~flavio/debian/fglrx-archive/msg01158.html ):
 
 
--- firegl_public.c-orig        2006-02-23 14:54:16.386740016 -0600
 
+++ firegl_public.c    2006-02-23 14:56:38.054203288 -0600
 
@@ -361,13 +361,15 @@
 
  } firegl_drm_stub_info_t;
 
  static firegl_drm_stub_info_t firegl_stub_info;
 
 
-#if LINUX_VERSION_CODE < 0x020400
 
+#if LINUX_VERSION_CODE > 0x02060F
 
  struct firegl_drm_stub_info_t *firegl_stub_pointer = NULL;
 
  #define inter_module_put(x)
 
  #define inter_module_unregister(x)
 
  #define inter_module_get_request(x,y)  firegl_stub_pointer
 
  #define inter_module_register(x,y,z)    do { firegl_stub_pointer = z; } while (0)
 
+#endif
 
  /* This is a kludge for backward compatibility that is only useful in DRM(stub_open) */
 
+#if LINUX_VERSION_CODE < 0x020400
 
  #define fops_put(fops)      MOD_DEC_USE_COUNT
 
  #define fops_get(fops)      (fops); MOD_INC_USE_COUNT
 
  #endif // LINUX_VERSION_CODE < 0x020400
 
 
  
 
XVideo support using the VideoOverlay option may not work with recent drivers. With version 8.29.6 of the fglrx driver, you can instead use
 
XVideo support using the VideoOverlay option may not work with recent drivers. With version 8.29.6 of the fglrx driver, you can instead use
Line 81: Line 67:
 
Use the '''xvinfo''' utility to verify if XVideo support is available.
 
Use the '''xvinfo''' utility to verify if XVideo support is available.
  
=== Linux kernel Framebuffer driver ===
+
=== Proprietary ATI driver on Ubuntu Feisty ===
Works with the VESA driver at 1280x1024 (you have to append {{bootparm|vga|794}} to the kernel boot parameters)
+
On my Lenovo R60 (9641HYM) I had a similar system hang (on return from sleep) as described on the  [[ATI_Mobility_FireGL_V5200]] , and a similar fix (Step 3) seemed to get my laptop to wake up safely.
 +
 
 +
That fix is to edit /etc/default/acpi-support. Change the line POST_VIDEO=true to read POST_VIDEO=.
 +
 
 +
=== Proprietary ATI driver on Ubuntu Lucid ===
 +
On my Lenovo T60 (2007-G5G), the screen remained full of white vertical lines on a black background after resume. A double VT switch (Ctrl-Alt-F1, Ctrl-Alt-F7) was needed to make the screen work again.
 +
 
 +
A fix that worked for me was to edit /etc/default/grub, replace the line GRUB_CMDLINE_LINUX="" with
 +
 
 +
  GRUB_CMDLINE_LINUX="nomodeset"
 +
 
 +
and run update-grub. (See https://bugs.launchpad.net/ubuntu/+source/linux/+bug/425264 .)
 +
 
 +
=== Proprietary ATI driver and suspend2 ===
 +
It works perfetctly, but you need to set this parameter:
 +
  echo 20000 >/sys/power/suspend2/extra_pages_allowance
 +
 
 +
== Linux kernel Framebuffer driver ==
 +
Works with the VESA driver at 1280x1024 (you have to append {{bootparm|vga|794}} to the kernel boot parameters) and 1400x1050 ({{bootparm|vga|837}}). Does not work wirh vesa-tng at more than 1024x768 :(
  
=== ThinkPads this chip may be found in ===
+
== ThinkPads this chip may be found in ==
 
* {{T60}}
 
* {{T60}}
 
* {{Z61m}}
 
* {{Z61m}}

Latest revision as of 14:33, 24 September 2010

This is an ATI video adapter.

Features

  • Chipset: ATI M54
  • PCI ID: 1002:7145
  • PCI Express x16
  • 128MB GDDR1 video memory
  • Up to 512Mb HyperMemory

Linux X.Org driver

Supported.

There is the radeonhd which is developed based on the published specs by AMD/ATI. It appears that most of this work is being merged into the radeon (aka, ati) driver. On my system, the radeon driver has better 3D performance and is more stable than the radeonhd driver.

There is also the deprecated experimental avivo driver which works, but does not yet support any 3D acceleration.

ThinkPad LCD

Display on the internal LCD works as long as you set the monitor settings correct.

External VGA port

(Z61m): Works, but only if the X-server detects something plugged in here, eg. before X started or after a restart.

(T60): use aticonfig --enable-monitor=lvds,crt1 to clone onto the VGA port. I use this to drive projectors all the time. Note that only the physical resolutions of the VGA port and the LVDS can differ (that means that if you use clone mode, you can have a 1400x1050 internal screen and 1680x1050 external and use both of them at the same time, but the internal screen will show only a portion of the real "desktop"; this area shifts when you move your mouse towards the edge of the viewport).

SVideo port

??

DVI port

??

Linux X.org vesa driver

The vesa driver works out of the box. If you can't make it to show higher resolutions, you may try to use lower color depth -- the best fonts sizes on 15.4 widescreen were achieved with 1400x1050 at 16 depth (highcolor).

Proprietary ATI driver

Proprietary fglrx driver version 8.24.8 adds support for the x1400 chipset (according to ATI changelog). It works, including dualhead, 3d and video (XV) acceleration, when using the fglrx kernel module. (Without it, you get screen corruption including underlined mouse pointers.)

Sample "Device" section for xorg.conf:

Section "Device"
       Identifier  "ATI Graphics Adapter 0"
       Driver      "fglrx"
       Option      "ForceMonitors" "lvds,crt1"
       Option      "Centermode" "off"
       Option      "VideoOverlay" "on"
       Option      "OpenGLOverlay" "off"
       Option      "OverlayOnCRTC2" "0"
       Option      "PseudoColorVisuals" "off"
       Option      "HSync2" "31-64"
       Option      "VRefresh2" "56-75"
       Option      "UseFastTLS" "off"
       Option      "Mode2" "1280x1024,1024x768,800x600,640x480"
       BusID       "PCI:1:0:0"
EndSection

XVideo support using the VideoOverlay option may not work with recent drivers. With version 8.29.6 of the fglrx driver, you can instead use

       Option          "TexturedVideo" "on"

Use the xvinfo utility to verify if XVideo support is available.

Proprietary ATI driver on Ubuntu Feisty

On my Lenovo R60 (9641HYM) I had a similar system hang (on return from sleep) as described on the ATI_Mobility_FireGL_V5200 , and a similar fix (Step 3) seemed to get my laptop to wake up safely.

That fix is to edit /etc/default/acpi-support. Change the line POST_VIDEO=true to read POST_VIDEO=.

Proprietary ATI driver on Ubuntu Lucid

On my Lenovo T60 (2007-G5G), the screen remained full of white vertical lines on a black background after resume. A double VT switch (Ctrl-Alt-F1, Ctrl-Alt-F7) was needed to make the screen work again.

A fix that worked for me was to edit /etc/default/grub, replace the line GRUB_CMDLINE_LINUX="" with

 GRUB_CMDLINE_LINUX="nomodeset"

and run update-grub. (See https://bugs.launchpad.net/ubuntu/+source/linux/+bug/425264 .)

Proprietary ATI driver and suspend2

It works perfetctly, but you need to set this parameter:

 echo 20000 >/sys/power/suspend2/extra_pages_allowance

Linux kernel Framebuffer driver

Works with the VESA driver at 1280x1024 (you have to append vga=794 to the kernel boot parameters) and 1400x1050 (vga=837). Does not work wirh vesa-tng at more than 1024x768 :(

ThinkPads this chip may be found in