Difference between revisions of "AD1984"

From ThinkWiki
Jump to: navigation, search
(Debian script to build module (with module-assistant))
(Linux ALSA driver)
 
(25 intermediate revisions by 15 users not shown)
Line 4: Line 4:
 
<div style="margin: 0; margin-right:10px; border: 1px solid #dfdfdf; padding: 0em 1em 1em 1em; background-color:#F8F8FF; align:right;">
 
<div style="margin: 0; margin-right:10px; border: 1px solid #dfdfdf; padding: 0em 1em 1em 1em; background-color:#F8F8FF; align:right;">
 
=== AD1984 ===
 
=== AD1984 ===
This is a ''Analog Devices'' High-Definition Audio controller
+
This is a ''Analog Devices'' High-Definition Audio codec
  
 
=== Features ===
 
=== Features ===
Line 14: Line 14:
  
 
=== Linux ALSA driver ===
 
=== Linux ALSA driver ===
This device isn't supported by current Alsa Driver [http://www.alsa-project.org/alsa-doc/index.php?vendor=vendor-Analog_Devices#matrix] (as of May 25, 2007).
+
* This device is supported by the alsa driver since 1.0.15 (including R61/T61/X61 bugfix)
 +
* This device is supported by the kernel since 2.6.23 (which includes alsa 1.0.15 !) by the snd-hda-intel kernel module.
  
However, Takashi Iwai has added support to this device in Alsa development version [http://hg.alsa-project.org/alsa-kernel/log?rev=AD1984]... Still have to wait to get it included in the Linux Kernel...  Note: It is rather trivial too get this working in a standard kernel right now, It is only 3 patches on top of the stock 1.0.14 code:
+
==== For previous versions  ====
 +
 
 +
However, Takashi Iwai has added support to this device in Alsa development version [http://hg.alsa-project.org/alsa-kernel/log?rev=AD1984]... Still have to wait to get it included in the Linux Kernel...  Note: It is rather trivial to get this working in a standard kernel right now, It is only 3 patches on top of the stock 1.0.14 code:
  
 
* [http://hg.alsa-project.org/alsa-kernel/rev/958b39f3e8dd Fix Oops with AD1984 thinkpad model]
 
* [http://hg.alsa-project.org/alsa-kernel/rev/958b39f3e8dd Fix Oops with AD1984 thinkpad model]
Line 23: Line 26:
  
 
Alsa-Driver 1.0.14 added some support for this chip, but did not work on my T61; however, using the latest HG/Mercurial makes everything work.  I created a Debian package for unstable/sid with the HG alsa that works for me, available at [http://people.debian.org/~jello/alsa-modules-2.6.21-2-686_1.0.15~hg2007070601-1+2.6.21-5_i386.deb]. --[[User:Jello|Jello]] 15:31, 6 July 2007 (UTC)
 
Alsa-Driver 1.0.14 added some support for this chip, but did not work on my T61; however, using the latest HG/Mercurial makes everything work.  I created a Debian package for unstable/sid with the HG alsa that works for me, available at [http://people.debian.org/~jello/alsa-modules-2.6.21-2-686_1.0.15~hg2007070601-1+2.6.21-5_i386.deb]. --[[User:Jello|Jello]] 15:31, 6 July 2007 (UTC)
 +
 +
amd64 debian package here:
 +
http://www.cse.unsw.edu.au/~jdas417/alsa-modules-2.6.22-1-amd64_1.0.14-1_jda+2.6.22-3_amd64.deb
 +
--jashar
  
 
Works with Kernel 2.6.22 and Alsa 1.0.14a
 
Works with Kernel 2.6.22 and Alsa 1.0.14a
Line 29: Line 36:
 
Did not get it to work on X61s with either of the above packages. Newer HG packages do support this chip, so alsa 1.0.15 should have full support for this chip. --[[User:hjh|hjh]] 9:09, 27 July 2007 (UTC)
 
Did not get it to work on X61s with either of the above packages. Newer HG packages do support this chip, so alsa 1.0.15 should have full support for this chip. --[[User:hjh|hjh]] 9:09, 27 July 2007 (UTC)
  
Debian users (both Stable/Etch and Testing) can use the small script [http://www.klabs.be/~fpiat/linux/debian/Lenny_on_Thinkpad_T61/#Sound 1] i wrote to patch and build an alsa module package (with module-assistant). --[[User:Fpiat|Fpiat]] 11:45,04 August 2007 (UTC)
+
Debian users (both Stable/Etch and Testing) can use the small [http://www.klabs.be/~fpiat/linux/debian/Lenny_on_Thinkpad_T61/#Sound script] I wrote to patch and build an alsa module package (with module-assistant). --[[User:Fpiat|Fpiat]] 11:45,04 August 2007 (UTC)
  
=== Trouble shooting ===
+
Works with a patched 2.6.22.1 kernel using the 2007/07/20 patch from ftp://ftp.alsa-project.org/pub/kernel-patches/ . Just make sure that you have the PCM channel unmuted and the speaker switch checked. --[[User:Mozz|Mozz]] 17:13, 7 August 2007 (UTC)
{{WARN|It's really necessary to leave the modem enabled in the BIOS or the intel_hda-driver will reutrn azx_get_response timeouts which will lead to a non-working soundchip.
+
 
 +
Above patches are in kernel mainline from Kernel 2.6.23-rc1 , it works on my T61 --[[User:Brain79|Brain79]] 22:01, 09 August 2007 (UTC)
 +
 
 +
Worked on my T61 running Debian Lenny, with a sid 2.6.23 kernel. (That is, I installed Lenny (and so have a Lenny version of ALSA - 1.0.14, and then upgraded the kernel to 2.6.23 from the sid repositories). [[User:Kyle Barbour|Kyle Barbour]] 09:46, 13 February 2008 (CET)
 +
 
 +
Not working with 2.6.24.2 and alsa 1.0.16 on T61 --Linea 23 March 2008
 +
 
 +
=== Troubleshooting ===
 +
{{WARN|It's really necessary to leave the modem enabled in the BIOS or the hda_intel driver will reutrn azx_get_response timeouts which will lead to a non-working soundchip.
 
Got that information from a comment from: [http://crypto.riken.go.jp/archives/linux/kernel.org/kernel/people/akpm/patches/2.6/2.6.22-rc6/2.6.22-rc6-mm1/broken-out/git-alsa.patch here] --[[User:Gladiac|Gladiac]] 06:12, 24 July 2007 (UTC)}}
 
Got that information from a comment from: [http://crypto.riken.go.jp/archives/linux/kernel.org/kernel/people/akpm/patches/2.6/2.6.22-rc6/2.6.22-rc6-mm1/broken-out/git-alsa.patch here] --[[User:Gladiac|Gladiac]] 06:12, 24 July 2007 (UTC)}}
 +
The reason modem must be enabled (at least on the x60,x61 series) is because the modem and sound share a bus.  (got that from calling lenovo hardware support today) [[User:Aliencam|Aliencam]] 01:43, 28 January 2008 (CET)
 +
 +
Remember the hardware mute on (some?) Thinkpads, including (at least some) Thinkpad T61s. If you don't have sound and all the requisite modules, versions, etc. are loaded and up-to-date, try pressing the physical volume up button a few times on your keyboard to turn it off. [[User:Kyle Barbour|Kyle Barbour]] 21:37, 26 December 2008 (CET)
 +
 +
{{HINT|ALSA did not recognise the sound card on my T61 when the driver was compiled in the kernel. After compiling it as a module it worked. [[User:xaxo|xaxo]] 18 Jun 2008}}
 +
 +
{{HINT|Many people have complained of keyboard noise (and ambient noise) being picked up by the mic and played back through the speakers (you will notice that the keyboard sounds "loud" until you mute sound).  FIX: turn down the mixer channel "Internal Mic Boost" from alsamixer's Playback menu.  There is another "Internal Mic Boost" in alsamixer's Capture menu, but that does not seem to have the same effect.}}
 +
 +
{{HINT|The hardware volume keys didn't work out of the box on my R61, using Debian Lenny with no GNOME or KDE.  It has been documented elsewhere that the R61 doesn't have a hardware mixer.  However xev did recognise the keys, so it was trivial to get them working.  This was solved by adding the following sections to .xmodmap and .xbindkeysrc respectively.  There is no need to restart Xorg, just xmodmap ~/.xmodmap && xbindkeys, and all should work.  You may wish to add a call to xbindkeys to your .xsession to avoid having to run it manually whenever Xorg starts. [[User:Antgel|Antgel]] 15:15, 7 October 2008 (CEST)}}
 +
 +
<pre>
 +
keycode 160 = XF86AudioMute     
 +
keycode 174 = XF86AudioLowerVolume   
 +
keycode 176 = XF86AudioRaiseVolume
 +
keycode 233 = XF86Forward
 +
keycode 234 = XF86Back</pre>
 +
 +
(Note the forward and back key entries, which work out of the box on Firefox 3.0.)
 +
 +
<pre>
 +
"amixer -c 0 set PCM 2dB+"
 +
XF86AudioRaiseVolume
 +
"amixer -c 0 set PCM 2dB-"
 +
XF86AudioLowerVolume
 +
"amixer -c 0 set PCM toggle"
 +
XF86AudioMute</pre>
  
 
=== This chip may be found in ===
 
=== This chip may be found in ===
* {{R61}}
+
'''AD1984'''
* {{T61}}
+
* {{X61}}, {{X61s}}, {{X61 Tablet}}
* [[:Category:X61|X61]], [[:Category:X61s|X61s]]
+
 
 +
'''AD1984A'''
 +
* {{X300}}, {{X301}}
 +
 
 +
'''AD1984JCP'''
 +
* {{R61}} (8914, 8919, 8920, 8927)
 +
* {{T61}} (6457, 6458, 6460, 6463, 6464, 6465, 8889, 8890, 8892, 8895, 8896, 8897)
 +
* {{T61p}}
 +
 
 +
'''AD1984HD'''
 +
* {{R61}} (7732, 7733, 7734, 7735, 7738, 7743, 7744, 7751)
 +
* {{R61i}} (7732)
 +
* {{T61}} (7664, 7658, 7659, 7661, 7663, 7665)
  
 
=== Datasheets ===
 
=== Datasheets ===

Latest revision as of 11:33, 3 March 2010

AD1984

This is a Analog Devices High-Definition Audio codec

Features

  • Chipset: AD1984
  • Interface: HD Audio

Linux ALSA driver

  • This device is supported by the alsa driver since 1.0.15 (including R61/T61/X61 bugfix)
  • This device is supported by the kernel since 2.6.23 (which includes alsa 1.0.15 !) by the snd-hda-intel kernel module.

For previous versions

However, Takashi Iwai has added support to this device in Alsa development version [1]... Still have to wait to get it included in the Linux Kernel... Note: It is rather trivial to get this working in a standard kernel right now, It is only 3 patches on top of the stock 1.0.14 code:

Alsa-Driver 1.0.14 added some support for this chip, but did not work on my T61; however, using the latest HG/Mercurial makes everything work. I created a Debian package for unstable/sid with the HG alsa that works for me, available at [2]. --Jello 15:31, 6 July 2007 (UTC)

amd64 debian package here: http://www.cse.unsw.edu.au/~jdas417/alsa-modules-2.6.22-1-amd64_1.0.14-1_jda+2.6.22-3_amd64.deb --jashar

Works with Kernel 2.6.22 and Alsa 1.0.14a --Schlodty 12:01, 21 July 2007 (UTC)

Did not get it to work on X61s with either of the above packages. Newer HG packages do support this chip, so alsa 1.0.15 should have full support for this chip. --hjh 9:09, 27 July 2007 (UTC)

Debian users (both Stable/Etch and Testing) can use the small script I wrote to patch and build an alsa module package (with module-assistant). --Fpiat 11:45,04 August 2007 (UTC)

Works with a patched 2.6.22.1 kernel using the 2007/07/20 patch from ftp://ftp.alsa-project.org/pub/kernel-patches/ . Just make sure that you have the PCM channel unmuted and the speaker switch checked. --Mozz 17:13, 7 August 2007 (UTC)

Above patches are in kernel mainline from Kernel 2.6.23-rc1 , it works on my T61 --Brain79 22:01, 09 August 2007 (UTC)

Worked on my T61 running Debian Lenny, with a sid 2.6.23 kernel. (That is, I installed Lenny (and so have a Lenny version of ALSA - 1.0.14, and then upgraded the kernel to 2.6.23 from the sid repositories). Kyle Barbour 09:46, 13 February 2008 (CET)

Not working with 2.6.24.2 and alsa 1.0.16 on T61 --Linea 23 March 2008

Troubleshooting

ATTENTION!
It's really necessary to leave the modem enabled in the BIOS or the hda_intel driver will reutrn azx_get_response timeouts which will lead to a non-working soundchip. Got that information from a comment from: here --Gladiac 06:12, 24 July 2007 (UTC)

The reason modem must be enabled (at least on the x60,x61 series) is because the modem and sound share a bus. (got that from calling lenovo hardware support today) Aliencam 01:43, 28 January 2008 (CET)

Remember the hardware mute on (some?) Thinkpads, including (at least some) Thinkpad T61s. If you don't have sound and all the requisite modules, versions, etc. are loaded and up-to-date, try pressing the physical volume up button a few times on your keyboard to turn it off. Kyle Barbour 21:37, 26 December 2008 (CET)

Hint:
ALSA did not recognise the sound card on my T61 when the driver was compiled in the kernel. After compiling it as a module it worked. xaxo 18 Jun 2008
Hint:
Many people have complained of keyboard noise (and ambient noise) being picked up by the mic and played back through the speakers (you will notice that the keyboard sounds "loud" until you mute sound). FIX: turn down the mixer channel "Internal Mic Boost" from alsamixer's Playback menu. There is another "Internal Mic Boost" in alsamixer's Capture menu, but that does not seem to have the same effect.
Hint:
The hardware volume keys didn't work out of the box on my R61, using Debian Lenny with no GNOME or KDE. It has been documented elsewhere that the R61 doesn't have a hardware mixer. However xev did recognise the keys, so it was trivial to get them working. This was solved by adding the following sections to .xmodmap and .xbindkeysrc respectively. There is no need to restart Xorg, just xmodmap ~/.xmodmap && xbindkeys, and all should work. You may wish to add a call to xbindkeys to your .xsession to avoid having to run it manually whenever Xorg starts. Antgel 15:15, 7 October 2008 (CEST)
keycode 160 = XF86AudioMute       
keycode 174 = XF86AudioLowerVolume    
keycode 176 = XF86AudioRaiseVolume
keycode 233 = XF86Forward
keycode 234 = XF86Back

(Note the forward and back key entries, which work out of the box on Firefox 3.0.)

"amixer -c 0 set PCM 2dB+"
XF86AudioRaiseVolume
"amixer -c 0 set PCM 2dB-"
XF86AudioLowerVolume
"amixer -c 0 set PCM toggle"
XF86AudioMute

This chip may be found in

AD1984

AD1984A

AD1984JCP

  • R61 (8914, 8919, 8920, 8927)
  • T61 (6457, 6458, 6460, 6463, 6464, 6465, 8889, 8890, 8892, 8895, 8896, 8897)
  • T61p

AD1984HD

  • R61 (7732, 7733, 7734, 7735, 7738, 7743, 7744, 7751)
  • R61i (7732)
  • T61 (7664, 7658, 7659, 7661, 7663, 7665)

Datasheets